Highlighted
CraigG58
1 Nickel

No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

I have an Inspiron 7000 2-in-1 that I just upgraded to Windows 10. Following the upgrade, automatic screen rotation stopped working, and I could not enable it since the button in the notifications area to do so was grayed out. I also found the checkbox to enable it in the display settings dialog, but after enabling that the screen still refused to auto-rotate.

Note that this function was working fine under Windows 8.1, so I know it can't be a hardware problem.

I then went into Device Manager and removed the two sensor devices, figuring that Windows would detect them and re-install the drivers for them once I rebooted. Unfortunately it didn't, and the sensor devices are still gone in Device Manager. I've never seen a version of Windows that didn't detect missing drivers for existing hardware following a reboot, and re-install them automatically.

Now, every option to enable screen rotation has disappeared, so Windows apparently doesn't know the motion detectors exist.

I've looked everywhere for drivers for these devices so I could install them myself, including the Dell support site using my service code number, and have drawn a complete blank. Where can I obtain the drivers for the sensor devices, or otherwise get this problem fixed?

Please help, a 2-in-1 is pretty useless if I can't get the display to auto-rotate. Thanks in advance!

0 Kudos
11 Replies
CraigG58
1 Nickel

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

Well, seems I figured this out...

When you uninstall the sensor devices using Device Manager, Windows 10 does not detect them following a reboot and automatically install drivers like Windows would normally do for any other device (as long as you have that setting enabled in the "Devices and Printers" dialog, it's on by default), as I had previously mentioned.

This is because the sensor drivers for my model laptop (Dell Inspiron 7000 2-in-1 (7348)) are part of the Dell "Intel Chipset Driver" package. There's absolutely no mention of this on the downloads page, which obviously isn't very helpful:

www.dell.com/.../DriversDetails

Once I installed this package, all of the controls for screen rotation reappeared, but they were still grayed out.

Turns out the controls for screen rotation now gray out when you have the laptop open in the "normal" position, that being with the keyboard on your work surface and the screen tilted back as you would normally use any other laptop. Once you either place the laptop on tent orientation or with the keyboard completely folded back, those controls "un-gray" themselves and can then be changed. To the best of my knowledge, this was not the case in Windows 8.1, and it's an easy trap to fall into.

Live and learn I guess, but this isn't an obvious issue that's easily understood, or at least it wasn't to me. Hopefully this helps someone out.

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

Craig58....You have been God sent.  I have been working on this for 3 hours and could not figure it out.  Thank you!!  Thank you!!

0 Kudos
CraigG58
1 Nickel

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

You're quite welcome, very happy this info helped someone out!

0 Kudos
camisotro
1 Nickel

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

Thanks for the info!

I also wanted to comment - last year's Inspiron 13 7347 does not have W10 drivers posted yet. However most of the 7348 drivers appear to work. I think it's identical hardware, just that the processor was upgraded from 4th gen in mine to 5th gen in yours. I would not try the BIOS files on the wrong model but probably everything else would be harmless to try.

So in my case the chipset drivers installed happily. Then I found this thread and it showed me how to open the rotation lock. Much better Smiley Happy

0 Kudos
Gansub
1 Copper

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

Thanks Craig.. I have been struggling with this. 

0 Kudos
skeff
1 Nickel

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

Definitely, a big thanks.

I just got this computer a few days ago and while getting used to it, am finding new issues that Dell isn't helping me with (chat apparently doesn't support my model number, etc)

This was the fixed for me with this issue.

Now to see if this passive stylus will ever work...

0 Kudos
CraigG58
1 Nickel

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

I'm really glad I took the time to post the fix for this issue, in that it's actually helping some folks out. Some people who find fixes to problems in various Internet forums often don't take the time to do that, and you wind up finding your question, with no answer. Very frustrating.

As for the stylus, mine seems to work fine. But, I think I've used it twice since I got this machine. Pointing with my finger works just as well, without having to dig the thing out. The tip of it is also too wide for my taste. I guess it's nice to know it's there anyway, although to me it's pretty useless.

If yours isn't working and your finger is, I would think it's probably not a hardware issue, but who knows. I had a look in Device Manager, and it isn't obvious to me which driver controls touch. Guess some further searches are in order to find that information, sorry I can't help there.

0 Kudos
wmata
1 Copper

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

Hello Craigg58, thank you for your input, unfortunately I've tried it and it didn't work, any other rec?

0 Kudos
CraigG58
1 Nickel

RE: No automatic screen rotation on Inspiron 7000 2-in-1 following Windows 10 upgrade

Jump to solution

Hi WMATA...

Some of these suggestions may be obvious, but I wanted to run them by you anyway in the hope they will help.

Are you sure you placed the machine in either tent or tablet orientation (with the keyboard folded completely back) before attempting to access the "screen rotation" button? It won't "un-gray" until you do, at least if you're running Windows 10. I'm fairly certain it worked fine running Windows 8, without making any changes to the machine at all.

If you're indeed running Windows 10, be 100% sure you've done what I previously wrote regarding drivers, specifically the "Intel Chipset Driver" 7348 driver package for Win 10. One more thing you might try before doing this: Prior to installing that new driver package, I removed both sensor devices via Device Manager, then rebooted. You probably already realize this, but they're both under "Sensors" in DM. After the reboot, check Device Manager again and they should still be gone. After that, then install the driver driver package. I'm not sure if this had anything to do with fixing the issue for me, but it's definitely worth a try.

Looks like my old link to the proper driver somehow went south for some reason, hopefully this one will work. If not, just search Dell's driver section for that title for Windows 10 and the 7348 machine.

www.dell.com/.../DriversDetails;fileId=3474967377&osCode=WT64A&productCode=inspiron-13-7348-laptop&languageCode=EN&categoryId=CS

There's also a setting in "Display" on the Control Panel that has a box labeled "Allow the screen to auto-rotate". Make sure that's checked, but that alone didn't fix my problem before I installed the new drivers. Again, might be worth a try though.

Control Panel\All Control Panel Items\Display\Screen Resolution

Hope something in here helps you out. Otherwise, you may have a hardware issue with the sensors themselves. If you suspect that, as painful as it may be, you may need to contact Dell tech support for further troubleshooting.

Good luck with solving this, please let everyone know how you made out!

0 Kudos