Highlighted
ogrex
1 Copper

No video, beeping, Insp 7520 (15R SE) recommendations?

Hello.  

I have an Insprion 7520 (15R SE) that is out of warranty. Has served me well for nearly 4 years now, no major issues, no recent hardware/software updates.  Occassionally I would get a random blue screen when reading from the SD card but it was inconsistent and always recoverable.

Last week I got a blue screen and haven't been able to recover. Machine is giving a singular beep, and there is no video being output to the local LCD or the external monitor typically connected. 

This particular machine was fitted standard intel HD video as well as an additional video card. Default video was set to the video card (not on-board video).

I understand the the singular beep is usually indicative of a motherboard failure or BIOS issue, but I've also read some anecdotal stories that related this issue to a problem with the external graphics card, but the system wasn't defaulting back to the on-board video.

Any recommendations on additional troubleshooting? Is there a method for resetting BIOS to factory default (there is no BIOS PW to worry about)?  

NB: the beeping I'm hearing is identical to that found in this Youtube clip (different model, same beeping) www.youtube.com/watch

0 Kudos
2 Replies
9 Rhodium

RE: No video, beeping, Insp 7520 (15R SE) recommendations?

Single beep is a BIOS failure -- the mainboard needs to be replaced.

0 Kudos
ogrex
1 Copper

RE: No video, beeping, Insp 7520 (15R SE) recommendations?

Given the age of the machine - I doubt it is financially viable to replace the MB, unless someone knows of a source?

Is there any value to just trying to reset the BIOS at a hardware level?  Is that even possible?  I'm very much out of touch with hardware in the last 5 years as I've not had time to do much tinkering.

0 Kudos