Potential fix for BSOD (WIN 10) on Dell Inspiron 5559 after installing new BIOS (1.4.1)

Hi, today i had an issue with my laptop that i wanted to share my fix for.

Issue: BSOD on startup, message: "MEMORY_MANAGEMENT" stopcode. bootloop cannot access win 10.

Effectively, i 0'ed the harddisk checked all memory and fully formated with new windows 10, not working still.. so I tried a large number of BIOS based and rescue tool based fixes, still not .... I realised that when i erased win 10 from harddisk that it was still loading win 10 and crashing?!?! strange, but i assumed it was the CMOS/NVRAM? maybe

Fix (for me): Disable PTT security from the BIOS. AND ctrl+esc as i turn on (with power cable connected AC).

Image of PTT security on my BIOS:

when i attempted to go into a miniXP or win 7, i would also get issues, on XP it said BIOS not ACPI compatible, idk anything about what that means.

anyway thanks for reading, just putting out 1 more potential fix (for me anyway) for BSOD Bootloop issue if any1 else has it.

Does any1 know why that may have fixed it? either way i am posting just to share my experience