Highlighted
2 Bronze

Power conservation issue with i5-5300u in Latitude E7450

Jump to solution

Prior to re-installing Windows 10 on my E7450 last week, my processor (i5-5300u) would automatically clock down to 499 MHz at 0.6 watts, while idling.  After re-installing the OS and applying the same drivers from Dell Support that I was running prior to the reload, the processor will not go below 798 MHz or 1.5 - 1.8 watts, which means it now consumes roughly 3x more power at idle.  This change in behavior is complemented by a marked decrease in overall battery life (estimated as well as actual).

Prior to the OS reload, with CPU usage limited to 20%, clock speed limited to 500 MHz, and display brightness at the lowest level, the system would estimate up to 12 hours of idle time on a full battery.  Afterward, the most it estimates is roughly 8 hours.  Actual usage times are far less, dropping from around 10 hours prior to the reload to 6 or so hours after the reload.  No changes to the hardware configuration or BIOS have been made, and the battery's capacity/health has remained at 98.6%.

Oddly, when set to a power profile in which the processor power is more limited when the system is running on battery power, immediately after unplugging the AC adapter, the clock speed momentarily drops to 499 MHz, then increases to 798 MHz, where it remains.  Additionally, when running Ubuntu 17.04 from the same SSD, the system estimates over 13 hours of runtime while idling, indicating the loss in power conservation capability is related to my installation of Windows, and not the BIOS or hardware.  I've tried both the drivers from Dell, as well as those provided automatically by Windows Update.

I'm doubtful that anyone will have any definitive answers, as I've thoroughly searched both Intel's and Dell's support communities as well as the internet in general with no luck, but I'm optimistic someone will at least have some ideas for me to pursue or information to consider.

Feel free to share any thoughts you have or observations you've made related to your own system's power conservation/consumption, as long as it involves an Intel processor.  Thanks!

0 Kudos
1 Solution

Accepted Solutions
Highlighted
2 Bronze

RE: Power conservation issue with i5-5300u in Latitude E7450

Jump to solution

Solution:

1) Remove battery

2) Disconnect CMOS battery

3) Reconnect both batteries after a minute or so

4) Reconfigure BIOS

Minimum CPU power is back down to 0.6 watts, & estimated runtime while idling is back up to 12-13 hours.

View solution in original post

1 Reply
Highlighted
2 Bronze

RE: Power conservation issue with i5-5300u in Latitude E7450

Jump to solution

Solution:

1) Remove battery

2) Disconnect CMOS battery

3) Reconnect both batteries after a minute or so

4) Reconfigure BIOS

Minimum CPU power is back down to 0.6 watts, & estimated runtime while idling is back up to 12-13 hours.

View solution in original post