mrtonytlc
1 Nickel

Power issue with XPS 17, L702X

Although this laptop is older (2012), it is still very functional, fast, and I use it for everything (even though I just bought a newer XPS 15, 9560).  For awhile now, it has the problem where the power just randomly cuts out if it is off the power adapter for more than a few minutes.

It's not the battery.  I had the original battery tested, and it was fine.  I even replaced it with a newer battery (also tested and in excellent condition).  It's also not the adapter, which works fine.  I even bought a new one of those, which also works fine, despite a loose connection at the power-in side.

What could cause this drop out?  According to the battery guide I should a) have at least 3-5 hours of power when disconnected from the adapter, and b) get some kind of battery low warning before it shuts down... and it does not shut down or sleep... it just dies, as if the battery was removed completely and the power plug pulled unceremoniously.

While I'm asking questions, where can I get a replacement AC cord for my adapter?  The one with the three-prong plug on the adapter end.

Thanks!

Tony

0 Kudos
2 Replies
mrtonytlc
1 Nickel

RE: Power issue with XPS 17, L702X

Before I forget, it's also not the settings.  I checked those and everything is set to SLEEP after 30 minutes, and there is no "drop dead" option. Smiley Happy

0 Kudos
Moderator
Moderator

RE: Power issue with XPS 17, L702X

"loose connection at the power-in side"
Sounds like it is shorting out the system. Disassemble the laptop to reveal the RMD72 DC-in cable.


Be sure that the screw holding it affixed is secure. Re-seat the other end onto the motherboard. Dell is not going to have parts for this 2011 model. You will need to search on the web for a reseller for power cord part 199XY 240v or K055K, YJ782 250v.

0 Kudos