2 Bronze

Precision 5510 - video playback issues at 4K/UHD

When my 5510 (i7-6820HQ + UHD screen) arrived one of the first things I tried was viewing one of the many 4K videos on YouTube (in Chrome), and I was disappointed to find that it kept stuttering / dropping frames. Selecting 2K video resolution (within YouTube) seemed to playback smoothly enough and was still better than the 1080p quality I was used to so I was happy enough with that in the short term and assumed that buggy drivers/firmware were to blame for the 4K stuttering, as surely the i7 CPU (plus either the integrated Intel HD 530 GPU or the Quadro M1000M GPU) would be capable of decoding & rendering 4K video at 60fps...

However, many months have passed, I've installed endless driver & firmware updates, and nothing has changed, if anything playback performance feels worse, and I've even found that watching 1080p Blu-ray rips fullscreen at 4K screen resolution results in stuttering video (even on 24fps videos) and out of sync sound in both MPC-HC or MPD - and that's with the EVR presenter selected in both apps. I've also tried setting the LAV Video Decoder filter to use QuickSync or CUVID but neither makes a difference.

Everything looks and feels like the CPU & GPU are doing all the right things and aren't working very hard (I've used CPU-Z and GPU-Z to keep an eye on load and nothing is maxing out, far from it, they're barely working at all - between 10-25% utilization depending on what I'm looking at) and the decoding is going fine but somewhere along the line those pixels are not being rendered to the screen fast enough and that's why I'm seeing the stuttering.

I've also found that my machine's i7 6820HQ CPU is performing well below its potential capabilities even when plugged in and on the maximum performance settings - this review shows that when tested using the popular CPU benchmarking tool wPrime 2.0x (which provides short [32M] and long [1024M] tests) an identical Precision 5510 gets a score of 7.6s at 32M (near identical performance to the same processor in a XPS 15) and this page corroborates that, showing that the i7 6820HQ CPU benchmarks at approx 7.9s for the 32M test and approx 235.9 for the 1024M test, whereas my 5510 benchmarks at 13.7s for the 32M test (1.7x slower) and 387.1s for the 1024M test (1.6x slower) so something is definitely wrong there, whether it's the CPU itself or something else.

So surely this can't be right? Surely my 5510 + i7 + UHD should be perfectly capable of playing back 4K video on its 4K screen without struggling? Has anyone else experienced this?

I've contacted Dell and I'm having trouble getting support to understand the problem let alone identify the cause but they say that if I can provide evidence that other 5510s aren't having the same issue then they can look into it further, so please can someone else with the same/similar configuration confirm that they can play back the 4K YouTube video below in fullscreen at 4K resolution without dropping any frames and post their service tag (via PM if you don't want to post it publicly)? It would be great if you could post your wPrime scores too for comparison.

Thank you in advance for your help!

And now please enjoy this video that I can't...

0 Kudos