Martin Kite
1 Copper

Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

Hi,

I have just upgraded from an E6410 to an E7440. I have two Dell 2007FP monitors connected via DVI on an E-series E-Port Plus dock. The native resolution of these monitors is 1600x1200 @ 60 Hz and my old E6410 was able to run this just fine. The new E7440 however refuses to see that 1600x1200 is available and has an upper limit of 1280x1024 @ either 60 or 75 Hz. The Intel graphics properties app does show that 1600x1200 @ 60 Hz is a supported mode of the monitor in the Information Center section, but it won't let me select it in the Display Options section.

Anyone know if this is a fundamental limitation of the docking connector on the new 7000 series or if I just have something set wrong somewhere? All the drivers are up to date as far as the Dell support site is concerned ... The machine is running Windows 7 64 bit if that makes a difference.

Thanks & regards,

  Martin

0 Kudos
2 Solutions

Accepted Solutions
Martin Kite
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

Sorry - should have come back sooner as my IT guys at work found the "fix". This is a driver update that is for the E7440 but doesn't come up if you search for E7440 updates (???). Anyway, I got the required driver from:

Whilst the link is from the E5540 area, the driver is for the Intel HD4400 GPU that is in the E7440 as well. This has fixed the issue on all the E7440s we have here.

Martin

0 Kudos
gbatty
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

We were experiencing this exact issue with the Dell 2007FPb displays. We were limited to 1280 x 1024 resolution when using a Latitude 7440 while docked. We needed the 32-bit version of the driver update (which is 9.18.10.3324) aka (A09). The 32-bit version can be found below. It worked perfectly and now I get a crisp 1600 x 1200 display resolution on my 2007FPb.

Thanks for starting this thread!

www.dell.com/.../DriversDetails

0 Kudos
8 Replies
Highlighted
kekekabic
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

Had the exact same problem. It's an issue with the MST HUB drivers/firmware. That fixed it for me. The update from dell is below.

http://www.dell.com/support/drivers/us/en/19/driverdetails?driverid=HW2WD

Jared

0 Kudos
lisko
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

Hi. I'm having the same problem with my Dell 2007FP attached to docking station and Dell Latitude E7440 using DVI cable. The driver upgrade didn't help, I tried both versions 2.17 and older 2.15 - the maximum resolution for 2007FP is still 1280x1024. 

0 Kudos
Martin Kite
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

Sorry - should have come back sooner as my IT guys at work found the "fix". This is a driver update that is for the E7440 but doesn't come up if you search for E7440 updates (???). Anyway, I got the required driver from:

Whilst the link is from the E5540 area, the driver is for the Intel HD4400 GPU that is in the E7440 as well. This has fixed the issue on all the E7440s we have here.

Martin

0 Kudos
lisko
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

Hi!This solved the problem and now I got the native 1600x1200 resolution for my antique 2nd display. Thank you Martin, I will pass this to PC support team of our company because I think many people are likely to face this while deploying the new laptops and docking stations.

0 Kudos
Patrick Amato
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

So... for me this problem came up after switching from a home docking station and then coming back to my office docking station. The monitors wouldn't pick up. A coworker got me a vga adaptor (so I could connect directly to the monitor). I thought, well maybe the cables got loose. They weren't, but for hoots I unplugged and replugged the monitor cables back into the docking station while the computer was on - and then it saw them. This worked for all the monitors.

So for me the solution was to

1) dock my computer

2)start it up and log in (by opening the lid when nothing displays on the monitors attached to the docking station)

3) disconnecting and reconnecting the cables from the the back of the docking station

0 Kudos
gbatty
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

We were experiencing this exact issue with the Dell 2007FPb displays. We were limited to 1280 x 1024 resolution when using a Latitude 7440 while docked. We needed the 32-bit version of the driver update (which is 9.18.10.3324) aka (A09). The 32-bit version can be found below. It worked perfectly and now I get a crisp 1600 x 1200 display resolution on my 2007FPb.

Thanks for starting this thread!

www.dell.com/.../DriversDetails

0 Kudos
brianh-pdx
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

Thanks to all who posted on this.  I tried all the suggestions, but the update to the docking station firmware turned out to be the fix.  Others may want to start there.

0 Kudos
YoMel33
1 Copper

RE: Problem with Latitude E7440, E-series dock & external monitors

Jump to solution

I experienced a similar issue with an E7440 and a Dell Pro2X docking station.  Initially I attempted to update the MST firmware (Synaptics_Hub_FW_2.15_update_ZPE.exe), but received the following error message: "Failed to find Synaptics MST DP HUB IC".

After speaking with Dell Pro Support, we determined a bad MST firmware chip on the motherboard was the cause.  I was also experiencing other random, erratic issues with the laptop, so my issue may have been more complex than others in the thread.

0 Kudos