1 Copper

RAS Async Adapter

I stupidly pressed the “on” switch for 10 seconds while the laptop Dell Model XPS 14 (L401X) (Windows 7 64 bit) was booting up. Afterwards, my wi-fi and USB Verizon Novatel 760 Mobile Modem weren’t working.

I checked device manager and sure enough I had errors in network adapters. I tried restoring to the next earlier restore point, 4 days earlier, but the restore failed.

I went to the Dell website and downloaded the Windows 7 64bit and download all chipset and network drivers. Then I uninstalled all devices in Device Manager - Network Adapter. The new drivers were all re-recognized after installing the drivers I just downloaded. (I think all but one of the drivers were restored.) (See existing devices below.) Then I rebooted. My wi-fi was restored, but the Novatel Mobile modem was not restored.


I tried installing the Mobile Modem and the current VZ Access Manager on a neighbor’s laptop and it worked.  So, it is not likely the Modem or VZ Access Manager software are to blame.


Just in case, I uninstalled and reinstalled the Verizon Manager, with the latest updates, software on my laptop. When I use the software the modem is detected and authenticated, has its green led on and shows signal bars like it has found a signal. But when I click “Connect WWAN”, I get the error message from VZ Access Manager, “Connection failed. The modem (or other connecting device) is already in use or is not configured properly.  Error 663.”  


In the Event Viewer Application log I get RASClient Error, “CoId={135362E9-B484-4E37-821D-B7136424F0CE}: The user RobertAdams-PC\Robert Adams dialed a connection named Verizon Wireless - VZAccess which has failed. The error code returned on failure is 633.  Event ID 20227”


When I have my Novatel plugged in, the Device Manager shows it as a Modem with asyncmacs.sys and modem.sys (6.17.00-16385) as drivers. I have those two files in Windows. Device Manager shows the device to be working properly. When the Novatel is unplugged, Device Manager shows no other modem.


I believe my problem is that I’m missing my RAS Async Adapter. I think it was in my list before my crash, but am not sure. Friends with Windows 7 (x64) have that on their hidden Device Manager-Network Adapter. (6.1.7601.1754/6.1.7600.16385, Win7_rtm.090713-1255, 6/21/2006, asyncmacs.sys in the windows/system32/drivers folder). RAS Async Adapter is not listed as an option in the “Manually Add Legacy Hardware Network Adapters Microsoft” section. I have no Unknown Devices in any of my Device Manager entries including hidden. I have my Del Install Driver CD.

How can I obtain and install the driver or otherwise repair this problem?

Tags (1)
0 Kudos
1 Reply
1 Copper

RE: RAS Async Adapter

I need to amend my notes above.  When I said I uninstalled all the Network Adapter items, I was not able to uninstall the eight WAN Miniports.

0 Kudos