tauntonboy
1 Copper

SATA AHCI issues following clean install of Vista Ultimate 32bit

Hi all

I have re-installed Vista Ultimate 32bit edition on my XPS M1330. I got a blue screen error (flashed and then disappeared) and windows was unable to start. I had to enter the BIOS and change the SATA configuration from AHCI to ATA in order for Windows to see the drive and load.

My questions are as follows and any help most gratefulll:-

1. How do I enable AHCI?
2. Will I have to install Vista again to make this happen?
3. Do I need to bother to do this i.e. what gains will I see & will it affect the laptop if I dont?

Thanks in advance for any assistance in this matter

Kind regards

Alistair
0 Kudos
2 Replies
Highlighted
sawaddi
3 Zinc

Re: SATA AHCI issues following clean install of Vista Ultimate 32bit

You have to enable AHCI before installing Vista.  If you change the mode after installing Vista, the HAL - hardware application layer is incorrect and you will get a blue screen. 
 
If you use the Dell Vista DVD that came with the system, it will have the AHCI/SATA driver integrated.  Older Dell Vista DVDs will not include the driver and it must be installed from a USB drive.  Retail versions also do not include the AHCI/SATA drivers/

XPS 8700 

XPS 14

0 Kudos
Dave576
3 Argentium

Re: SATA AHCI issues following clean install of Vista Ultimate 32bit

Alistair,

Hope you resolved this by now.

Thought I would add this for anyone else looking for this subject.

It worked for me. I'm running in RAID/AHCI mode and no HDD in RAID. External HD on eSATA is now hot plug and unplug-able (no 'safely Remove Hardware' though).

 

 

http://en.community.dell.com/forums/t/18719445.aspx?c=us&l=en&cs=19&s=dhs

 

Ron3452

Joined on 02/15/2005


Re: SATA II

08 Jul 2008 10:35PM

Here's what I did to enable AHCI/RAID mode on my Inspiron 530 (Q6600, Vista SP1, single drive):

 

  1. Download and install Intel Matrix Manager driver (R154092). Make a note of the folder location where you install the driver. 
  2. Open up Device Manager, expand IDE ATA/ATAPI controller branch
  3. Right-mouse click on either Intel(R) ICH9 Serial ATA Storage Controller (I selected the 4 port, both entries will change after the reboot at the end of this process) entry and select Properties
  4. Go to the Driver tab, click the Update Driver button
  5. Choose the Browse my computer for driver software option
  6. Choose the Let me pick from a list of device drivers on my computer
  7. Click on the Have Disk... button, browse to the location you installed the Intel Matrix Manager driver in step 1 and click on iastor.inf
  8. Click OK and select the Intel(R ICH8R/ICH9R SATA RAID Controller driver.
  9. Complete the process to update the storage controller driver.
  10. Restart the computer and press F2 to enter the BIOS and enable RAID mode (changing it from IDE)

 

After the computer starts up in AHCI/RAID, you can install the Intel Matrix Storage Manager Console application (R154079.EXE). You don't have to setup a RAID volume; the Storage Manager Console will show the hard drive as a non-RAID volume. 

 

- Ron

 

 

After a couple of days I had a forced shutdown error. It was the RAID driver so I downloaded the 8.8.0.1009.exe from the Intel website, just click on it, answer all the questions, re-boot and everything is working. I did notice that everything seems to be running a bit faster now!

Hope this helps,

Dave

 

_______________________________

Inspiron 530s, Intel Core2 E7200, 6 GB DDR2 800MHz, 500GB SATA II 7200RPM, 22" Widescreen LCD w/2 MP Webcam,Radeon HD4650, Windows 7 Ultimate 64bit,  eSATA port 

Studio Laptop 1737, Intel Core2 Duo T6400 800MHz , 4GB DDR2 memory 800MHz, Intel X25-V 40GB SSD, 320GB SATA II,17" WXGA w/2.0-megl webcam, Facial recognition, Windows 7 Ultimate 64bit, Vista Premium 64-bit,  eSATA port,  9-cell battery 
External HDD: A.C.Ryan w/500GB Seagate Barracuda SATA II 7200RPM w/eSATA, WD My Book 500GB 7200RPM w/USB
Custom Rig, i5-750, Gigabyte UD4P, Intel X25M 120GB SSD, 8GB Corsair Venegance CL8, XFX HD 5770, Corsair HX 650 PSU, 1TB and 500GB HDDs. Win7 Ultimate 64bit.
0 Kudos