kaavain
1 Copper

SSD freezing - I give-up.

So, nothing new but finally it makes me mad.

I've replaced on my E5450 HDD to SSD. The SSD drive (Kinston SSDnow V300, 480 Gb) worked 2 years before this on Acer notebook with no problems.

I've made a system image using W10 tool and recover it on SSD. Everything fine but some times SSD shows 100% active disc time while 0% of disk I/O usage. It takes from 20 sec to 2 minutes, most often after reboot/sleep. I've done many things so far - disabled hibernation, disabled pre- and superfetch.. many, many ways I've found in Internet. The driver o SATA is Intel genuine, the mode is ACHI. Everything - but nothing changes. Tested by chkdsk, checked by SMART - the disk is fine.

Today I've installed this SSD with the same system (and settings) to another NB, ASUS, and it works fine, with no freezes. But in my DELL nb - the things are the same.

It seems to be a hardware conflict. Would anybody solved this or have any other suggestions?

 

Tags (2)
0 Kudos
6 Replies
Moderator
Moderator

RE: SSD freezing - I give-up.

Thank you for your message.

Please run a hardware diagnostic by following this link http://bit.ly/2fJuGXB  with the SSD connected.

Check the event logs & see if there is numerous entries of Event ID 129.

Try the below steps:

1. Determine that the system is running the default AHCI driver (StorAHCI.sys): I.Open a command prompt with administrator privileges. Then type devmgmt.msc in the command prompt window and hit Enter.

II. Under IDE ATA/ATAPI Controllers right-click on the AHCI controller node and select Properties. This node is normally called “Standard SATA AHCI Controller.”

III. Click the Driver Details tab.

IV. If “StorAHCI.sys” is listed, the system is running the default driver.

2. Disable MSI for the controller in the registry:

I. In the same properties window opened in step 1.2, navigate to the Details tab and select Device instance path from the Property drop-down menu. Note this path.

II. Open the registry editor by typing regedit in the previously opened command prompt.

III. Navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\PCI\<AHCI Controller>\Device Parameters\Interrupt Management\MessageSignaledInterruptProperties, where <AHCI Controller> refers to the device instance path you noted in step 2.1.

IV. Change the value of the MSISupported key from “1” to “0”.

V. If you don’t know which controller your boot device is attached to, repeat steps 2.1 through 2.4 for all AHCI controllers found under 1.2.

3. Reboot the machine.

If the steps above do not resolve the issue, the following steps may provide a workaround: 1.Navigate to Control Panel

2. Select System and Security

3. Select System

4. Select Advanced System Setting

5. Under Performance, Select Setting

6. Select the Advanced Tab

7. Select Change

8. Set the minimum to the amount of System Ram installed

9. Set the Maximum to double the amount of System Ram installed

10. Select Apply

11. Select OK

12. Restart the system

This process increases the size of the Pagefile that Windows uses to ensure enough storage space is allocated to the Operating System.

Please click on my Dell username & send a private message with the service tag, registered name & email address.

0 Kudos
kaavain
1 Copper

RE: SSD freezing - I give-up.

As I said already, The ACHI driver is not MS, it is genuine Intel... And I did already MSI disabling... All other steps will try.

0 Kudos
kaavain
1 Copper

RE: SSD freezing - I give-up.

OK.

Passed F12 tests without any errors. Log is clear. No one events found.

Changing pagefile settings form auto (was about 2 Gb) to RAM-2xRAM (8-16 Gb) made th situation much more worse. After the reboot I've got 5 or 6 freezes for 1-2 minutes each (before it was much rare and for 15-20 seconds).

Now I've changed pagefile for DISABLED and after the reboot it works. No freezes so far.

As I told you, this SSD works fine on my old NB, but old NB has CD-ROM and I've installed old HDD in that place... And pagefile was pointed to HDD. THIS IS THE DIFFERENCE.

It seems that some conflict in settings while pagefile is pointed on SSD...

0 Kudos
kaavain
1 Copper

RE: SSD freezing - I give-up.

In 24 hours got 2 freezes... But only 2 in 24 hors, before disabling pagefile it was every wake from sleep at least.

Something wrong with the way which Windows uses to (resize?) pagefile. May be the problem is that Windows was not INSTALLED on the SSD (may be it detect that it is SSD and makes some changes?) but cloned from the existing HDD...

Any suggestions?

0 Kudos
kaavain
1 Copper

RE: SSD freezing - I give-up.

UPD: no luck... Freezes and freezes after wake from sleep. So I'll come back to the state "I give up"... After 2-3-4 freezes it works normally but just after sleep it is nightmare.

0 Kudos
kaavain
1 Copper

RE: SSD freezing - I give-up.

So, any other ideas? What I did so far:

- disabled prefetch/superfetch and some other Windows services. Nothing changed.

- disabled caching on this drive, nothing.

- changed to RAID and back to ACHI, nothing.

The thing is that NOTHING changed, behavior is still as it was, form time to time (most often after sleep, some times 2-3 times in few minutes) for 40-60 sec 100% active time while 0% I/O.... But after that notebook can work normally for hours...

Any actions won't change the behavior even a little.

The same SSD in another NB with the same system and settings works fine.

0 Kudos