Laptops General - Read Only

Last reply by 01-15-2015 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Studio XPS 16 - Keyboard Issue / Duplicate Characters

Hi folks

Just curious if anyone else is experiencing the same thing with a new Studio XPS 16 (40) laptop keyboard. Despite tweaking all the advanced settings re keyboard, inc key strike filters / "bounce", repeat and delay rates etc, every fifth or sixth word (or sometimes more frequently), I keep getting double strike / repeated chaaracters in words where they shouldn't be, unless I type REALLY slowly, almost one key at a time (versus my normal 4-6 finger typing! ;-).

I'm pretty sure it's not my typing style, as we have 4 other different Dell laptops, plus a desktop PC with separate keybooard, and it never happens on any. I've also never had this occur in the last 15 years in using a whole variety of different laptops and PC's in the office. Soo I think it must either be something to do with the physical construcction of the Studio XPS keboard or the software driver. But it's driving me crazy having to go back and correct every other word in e-mails and doocs constantly. Interested to know if anyone else has had this annoyance, and if so and they cured it, how!?

(Reposted due to the thought police having removed my first post for the most innocuous of very mild frustrateed expletives. So sue me for being somewhat irritated at having paid $2,500 for a brand new laptop which takes twice as long to type on as my old one, due to constant manual error coorrrectioon - as it was clearly built with zero quality ccontrol! - Perhapss Dell if you put as much effort into QA and integration testing as keyword search bots and administrator policing, these forums wouldn't be ABSOLUTELY chock full of disgruntled customers wondering if they should have bought a MAC instead).

Thaat aside, any views, experience or tips from other aaffllicted users much appreciated.

Many thanks

Hal

Replies (90)
2 Bronze
2 Bronze

After contacting the support i could solve the problem by installing BIOS version A08.

2 Bronze
2 Bronze

@ASlide

I have exactly the same problem with the same computer (M4800). In the German Dell forums is a thread where someone describes the same problem, too. He says, he experiences this problem since updating his BIOS.
We have - indepently - found out, that it's not caused by the way you type but, as a simple keylogger has shown instead, that the key release event is missing when you do a very short keytap.

2 Bronze
2 Bronze

KingdomSeeker, thanks so much for your reply, the solution in that thread worked!!  I'm typing this on my laptop keyboard and I'm not getting anymore double keys!  :)

2 Bronze
2 Bronze

I know this iss an old post, buut I just started a nnew job and I got a Precision M4800 and I'm having this samme typing issue.  It must be my typing style but it makes the keyboarrd bbaasically useless becausee I have to go back and change like every other word (as you can see in this senntence).  I'm an 8 finger typer and I type pretty fast annd hard.

I'mm using Windows 7 and there are a lot off optionss in the Filter Keys and I've played around withh all of them including a "Bounce Keys" option buut nnothing has fixed the problem.  I guess I'mm just going to haavve to learn to type softer or slower on this keyybboard...  Fortunately I havve a USB keybboard hhooked up to my docking station and of course that doesn't give me anny prroblems.  Mabbye I can just get a wireless USB keyboard to carry around with me whennever I'mm not on my dockking station (even thhough that pretty mmuchh defeats the puurpose of havving a mobile laptop).

Yep, this is hoow bad it is everry timme I try to tyype on this keyyboard.

Hi!

I solved the duplicate char changing some register key and turnin on the keyboard filter in control panel...like one old post...work also in win 8.1.

2 Bronze
2 Bronze

Hi ASlide

I started the original post 5 years ago when I just got my spanky-new, state of the art XPS Studio 16. I'm still using it today, great laptop - with the exception of the keyboard, which has this totally unfixable problem - as did several other sibling Dell laptops from around that time and a few years after.

I wasted tens of hours, fiddling with all the keyboard filters (I also type fast and hard, like you - but it's nothing to do with your typing, it's the keyboard). I had a replacement keyboard sent from Dell, and even tried some 3rd party bespoke keyboard driver software and filters. Nothing solves it. And if you type a lot of verbiage daily, and quickly - as you know, it's totally untenable to go back and proof-read and correct every duplication which happens a LOT!

However, the perfect solution for desk and travel is the brilliant little Bluetooth wireless Logitech K810 illuminated keyboard, which can be programmed to work with 3 devices (laptop, tablet and smartphone) and toggle between any at the tap of a button. It's super light and small (yet "proper sized" compact keyboard - but no numeric pad) with proper (spaced apart) keys that give enough travel. It's also rechargeable from the laptop with micro USB lead (no batteries required).

So I would highly recommend this for both home, office and travel.

Still love Dell laptops (the top of the range ones), have bought a dozen for the family in last 10 years. And happy to say the latest range of XPS 15s are flawless and keyboard is perfect. I will probably be finally upgrading my trusty XPS16 to a newer one at the end of this year, only for sheer CPU, graphics card and RAM requirements to keep pace with web.

Hope that helps.

Cheers

Hal-9001

3 Silver

Sorry to see your Dell keyboard problems - it is painful to read through all those doubled keystrokes (painful because I experienced them too). Did you try the procedure outlined here: http://en.community.dell.com/support-forums/laptop/f/3518/t/19328066.aspx?pi239031352=4 Look near the bottom of Page 4 of the thread as posted by sweaver2112. You will want to follow the procedure exactly, as it has some subtleties to it. If you haven't tried that yet, then maybe it will help.
2 Bronze
2 Bronze

I know this iss an old post, buut I just started a nnew job and I got a Precision M4800 and I'm having this samme typing issue.  It must be my typing style but it makes the keyboarrd bbaasically useless becausee I have to go back and change like every other word (as you can see in this senntence).  I'm an 8 finger typer and I type pretty fast annd hard.

I'mm using Windows 7 and there are a lot off optionss in the Filter Keys and I've played around withh all of them including a "Bounce Keys" option buut nnothing has fixed the problem.  I guess I'mm just going to haavve to learn to type softer or slower on this keyybboard...  Fortunately I havve a USB keybboard hhooked up to my docking station and of course that doesn't give me anny prroblems.  Mabbye I can just get a wireless USB keyboard to carry around with me whennever I'mm not on my dockking station (even thhough that pretty mmuchh defeats the puurpose of havving a mobile laptop).

Yep, this is hoow bad it is everry timme I try to tyype on this keyyboard.

3 Argentum

I have found the issue is with microsoft.. When I type letters are missing or else there is a delayed action. Microsoft has issue a problem about this. I just can't comprehend what they are saying the problem is. As far as dell they couls care less.

3 Silver

falessi, it is unfortunate that the Autohotkey utility (thread link is two posts back) did not run correctly on your Dell. Yours is the only case that I have seen where it did not work. Thanks for listing the FilterKeys approach, which also works well. For reader reference, that approach is also listed in detail in the other thread.

2 Bronze
2 Bronze

I have tried the software used in link you have posted some mounth ago, but isn'worked...i tried one win 7 registry hack and it was the only (I haved alsi developed a software working only for XPS-1645 italian keyboard) way to fix the problem....

at the present time my DELL XPS is died....and I haven't a DELL pc....

the ak is:

You have to enable FilterKeys in the control panel before edit the register

then you have to modify the regiser key (is a good idea to write the original values in piece of paper ;-P )

HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response

 {

AutoRepeatDelay: 500

AutoRepeatRate: 1

BounceTime: 0

DelayBeforeAcceptance: 18

}

If you type faster than me, you can decrease the DelayBeforeAcceptance.

 

the link at the page is : http://en.community.dell.com/support-forums/laptop/f/3518/t/19280281.aspx?PageIndex=5

try....

 


 

Top Contributor
Latest Solutions