Laptops General - Read Only

Last reply by 01-15-2015 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Studio XPS 16 - Keyboard Issue / Duplicate Characters

Hi folks

Just curious if anyone else is experiencing the same thing with a new Studio XPS 16 (40) laptop keyboard. Despite tweaking all the advanced settings re keyboard, inc key strike filters / "bounce", repeat and delay rates etc, every fifth or sixth word (or sometimes more frequently), I keep getting double strike / repeated chaaracters in words where they shouldn't be, unless I type REALLY slowly, almost one key at a time (versus my normal 4-6 finger typing! ;-).

I'm pretty sure it's not my typing style, as we have 4 other different Dell laptops, plus a desktop PC with separate keybooard, and it never happens on any. I've also never had this occur in the last 15 years in using a whole variety of different laptops and PC's in the office. Soo I think it must either be something to do with the physical construcction of the Studio XPS keboard or the software driver. But it's driving me crazy having to go back and correct every other word in e-mails and doocs constantly. Interested to know if anyone else has had this annoyance, and if so and they cured it, how!?

(Reposted due to the thought police having removed my first post for the most innocuous of very mild frustrateed expletives. So sue me for being somewhat irritated at having paid $2,500 for a brand new laptop which takes twice as long to type on as my old one, due to constant manual error coorrrectioon - as it was clearly built with zero quality ccontrol! - Perhapss Dell if you put as much effort into QA and integration testing as keyword search bots and administrator policing, these forums wouldn't be ABSOLUTELY chock full of disgruntled customers wondering if they should have bought a MAC instead).

Thaat aside, any views, experience or tips from other aaffllicted users much appreciated.

Many thanks


Replies (90)
2 Bronze
2 Bronze

Thanks for help!

I contacted Dell once again. This time i used the live chat. They sent me a technician the next day who changed the mainboard. But the problem was still there.
He telephoned to the Dell Solution Center and they confirmed that the problem of dublicate characters is a general design issue of the studio 16 xps' keyboard layout.
I said, that I bought the Studio 16 XPS for 90% text processing and 10% image processing and that because of the keyboard problem this notebook is useless to me.
And because of the fact, that Dell offers no other notebook with the 1080P RGB LED Display they retracted the notebook and repay the price.

2 Bronze
2 Bronze

You should at least get some direct response from the customer service live online chat. Start here:

When I talked with about this issue some time ago they said this was not a well-recognized issue because there was only one other complaint on these pages. Since then there have been many more complaints. You should point that out, supplying the address of these pages to them. Point out that a KB replacement is a waste of time given previous reports and that you want your money back or a different model. They have a 30 day rule beyond which refunds are not granted. But at some point, once enough people have complained, they may start to change their response. Good luck.

2 Bronze
2 Bronze

Three mails to the technical support within three weeks and no answer yet. :emotion-45:

I'm very annoyed.
I want to give my 5 month old studio xps back to Dell and want my money back.
Does anyone knows how to do this best?



2 Bronze
2 Bronze

Yes, the technical support is informed about the screw. This is two weeks ago. Last week I wrote a second mail because I didn't get an answer..

No reply since two weeks. :emotion-45:

2 Bronze
2 Bronze

The screw is interesting. Perhaps the KB is made too stiff at that point causing the keybounce to get much worse there. It offers hope that the problem can be fixed.

Did you alert tech support to these reports? If so what did they tell you?

2 Bronze
2 Bronze

Hi at all!

Mine has the problem, too. The Keys that are affected are i,o,k,l and space.
The technical support sent me two keyboard replacements but everyone has the same problem.
I also think, that it is a design problem of the Studio XPS's keyboard.
Directly behind the keys i,o,k,l is a little screw to connect keyboard and chassis.

For me, this notebook is completly useless.
It was bought because I wanted to write my PhD-Thesis on this thing. But if I have to correct evry 20th character is more than annoying!
My first Dell will be my last!

2 Bronze
2 Bronze

It seem Dell technical has turning a blind eye on this problem. No helpful advise or solution given.

I have updated the BIOS to A11 for M1340 but no lucks. I'm now running out of time.

I have to consider Dell repuation a serious issue, as we have plan to buy 10 high spec desktop PC for our office and possibly more laptop such as Dell Studio XPS 16.

Keyboard is fundamental operation of the system, it is defective and annoying, it seems technical experts perfer to drink tea than trying to fix the problem. I shall write to PWC or Computer Shopper and ask for advice.

A real shame, they make good PC/Laptop but not any more.....bye bye Dell.



2 Bronze
2 Bronze

Dear dell people - this problem is real! I'm experiencing it too, please do something about it.Furthermore, my : key seems to be resisting being pressed, which is _EXTREMELY_ annooying (the double o ii (and the double i) is the keyboard acting out).

This problem is really annoying, having in mind that otherwise the studio xps 16 laptop is awesome.

2 Bronze
2 Bronze


The only thing I cann say is that I'm glad to find out that I'm not alone.  I have bought 9 laptops from Dell for my company down through the years.  The last two I've had problems with the keyboards.  On both I replaced the keyboard to no avaial.  I slowed the repeat reate and delay and made sure the sticky keys were off.

The problem IS a hardware problem.  I believe it has to do withi typing too fast and too hard.  Notice the "i" on the word "with" in the last sentence.  the repeat on the keystrike is happening 3 letters later! This happens to me all the time.  Just like another blogger, I too am nont fixing the typing problems in this message for the sake of exammple.

The one thing I've noticed is that over time, the keyboard seems to break in.  I think the only real fix is to:

1. Try a different brannd of computer.

2. intentionally try to slow down your typinng and the force of the keystroke.

3. Attach an external USB keyboard (great idea since the purpose of the laptop was to minimize clutter...)  :(

Unfortunately, this will be the last Dell I buy.  Dell guys, I hope you are are monitoringg these commmunications.  There are a bunch of us out there that arae not happy.


2 Bronze
2 Bronze

Hey Folks

I've been experimenting with various combos of the Dell keyboard filter settings and have come up with one which I think mitigates 90% of the problem. It's not perfect, but I've found that the character duplicates that get missed are, by and large, then corrected by auto-spell as I type in Outlook and Word etc (though doesn't help with apps and chat forum message boxes without inline auto-corrrect).

But all said and done, reduces the amount of erroneous duplicates to low single percentage (so far, after 3 solid days of testing). Still not perfect, but for those of who really don't want to (yet!) or don't have an option to swap out / swap the Studio XPS for an alt laptop with someone who types lighter, it's certainly better than the 50%+ of words typed having dupes that I was experiencing before.

If anyone finds an even better combination I'd love to know. And if anyone from DELL actually has the decency to read this forum and post a useful reply on what you are doing about the keyboard drivers we would all really appreciate it and might then buy another DELL in the future and actually be able to still recommend the brand.

Assuming using Vista (not sure of the menu chain for XP) - Go to Control Panel / Ease of Access Centre / "Make the keyboard easier to use" option.

Select the "Setup Filter Keys" hyperlink

Next page - click "Turn On Filter Keys"

Select the "Turn on repeat keys and slow keys" radio button

Select the "Setup repeat keys and slow keys" hyperlink

Next Page

Select the "Slow down keyboard repeat rates" radio button

Choose 0.5 secs for first option, and 0.7 secs for second option.

Do not click any other options.

I didn't find the "Anti-Bounce" filter worked at all (despite this being the most obvious utility to use). But if anyone else has, either in isolattion or any combo with other filters. Please advise.




Top Contributor
Latest Solutions