Carsten Holz
1 Nickel

TB15 not working, even after following all driver update procedures

The TB15 cuts out every few minutes, briefly shutting down the XPS13 in that process. The two external monitors (2560x1440 and 1920x1080) attached to the TB15 cycle on / off for hours on end and eventually may not come on again. Most recently, a connected TB15 has also caused fatal crashes of the XPS13. Ethernet equally cuts out. Front USB ports don’t work.

I have followed the Thunderbolt TB15 Dock BIOS / Drivers Installation Guide ( over several months at least half a dozen times, most recently on 7 September 2016 -- with bullet item 8 not installing -- to no avail.

I have posted details of my experiences with the never-functioning TB15 at

Re bullet item 8 not installing:

Item 8, “ASMedia USB 3.0 Extended Host Firmware Utility” does not install. I get the message“C:\Users/CARSTE~1\AppData\Local\Temp\~sfx00149EB223\Asmio64.sys

The process cannot access the file because it is being used by another process.”

This is after I restarted the computer, opened Windows Explorer to double-click the installation file for this driver (which leads to an unzip and opens a window with a setup.exe file), then I closed Windows Explorer, then got the installation file to start. I.e., no other program was running.

I also tried to do the installation in Safe Mode. The installation seemed to start (though no agreement window opened up) and then nothing happened

I then dropped Safe Mode, disabled the anti-virus software, and tried installation. I am prompted for license acceptance, and once I accept, I get the same message as above, can’t access the file.

I disconnect TB15 and do the installation, to no effect.

I skip this one item and install the remaining drivers without problem. (And I wonder if item 8 is even part of the TB15 problem, because on previous TB15 driver installation rounds everything installed, and TB15 still didn't work.)

Restarting the computer (and disconnecting and reconnecting TB15) leads to both external monitors and Ethernet working – for about two minutes, before the same old game of cutting out every minute or two restarts (and right now, both external monitors are off, and the "Extend" monitor option cannot be clicked on the XPS13, with TB15 connected and providing electricity, no Ethernet).

-- A separate problem is the DA200 -- the HDMI connection does not work.

A solution would be much appreciated.
Dell owes me about USD 5,000 in time spent trying to fix their non-functioning docks.