SonyHome
1 Nickel

TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

I just got TB16 to replace  my TB15 and I'm noticing that my Dell W3415U which is connected to my TB16 HDMI port goes blank for few seconds comes back every few hours. Like the video signal suddenly stopped or something. Not sure what's causing it but it's bothering me since it's happening while in middle of my use. TB16 is connected to my XPS 15 9550 running Windows 10 Pro via Thunderbolt 3 port.

If you know how to resolve this I would appreciate any help.

Thank you.

1 Solution

Accepted Solutions
NNB-Downunder
1 Copper

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

Solved - I also had a second or so every 15 minutes, to sometimes more than an hour, where Video/Sound through HDMI cable to an external monitor from the TB16 was being 'lost'. Really just about 0.5 to 1.5 seconds, but it was annoying. I contacted Dell service and double checked all the latest video drivers had been updated (both Intel HD 630 and NVidia 1050 drivers) on XPS 15 9560 PC. Next, and what did the trick, was increasing screen refresh rate from 29 fps to 30 fps............and it has not missed a beat for the last day or so. So try updating screen refresh rate where possible.

38 Replies
Moderator
Moderator

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution


Hi,

Welcome to our community. Please make sure that the ports are intact and there is no loose connection. The screen going blank intermittently might be because of the lose ports.

0 Kudos
SonyHome
1 Nickel

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

Thanks for the reply but I do not believe it's due to lose ports. I switched from TB15 and I didn't have this issue prior to TB16. Just to be sure I just checked to connection again and it seems to be securely connected.

Thank you.

0 Kudos
Moderator
Moderator

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

Hi,


Thank you for the update. Please click here find the steps to update the TB16 driver manually. Also, update the monitor driver from the support site.


Please click here to access the support site.


Click on view products=> select your monitor=> click drivers and downloads=> update the firmware for the monitor.


Let us know the results.

0 Kudos
SonyHome
1 Nickel

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

My XPS 15 9550 has all the latest drivers as I have been keeping it updated for TB15. There is some issue with the TB16 where the display connected to TB16 goes blank for few seconds and comes back. It's intermittent issue where I may notice this just few times the whole day and sometimes it happens once every few minutes for short period of time then stop doing it.

I didn't have this particular issue with the TB15 so this is definitely new issue that comes from the TB16.

0 Kudos
samos1111
3 Argentium

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

Interference with the 1830 wifi card is sometimes blamed for TB3/USB-C problems. You might want to test if the issues persists with the wifi card in Airplane mode or disabled in Device Manager. At the same time you can test the stability of the wired Ethernet connection.

0 Kudos
Roger Whitley
1 Copper

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

I just got my TB16 and am having the same problem with a monitor connected via Displayport to my XPS 9550. The entire connection to the TB16 seems to be lost for a few seconds, not just the monitor. I lose USB speakers and an external USB drive which are also connected through the TB16. I also have all the latest BIOS, firmware, and drivers.  However, I found the 1.2.19 bios was making this problem worse. I rolled back to 1.2.18.

0 Kudos
Moderator
Moderator

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

Please be certain that you have completed all updates listed in this article.  Not updating can cause the issues  you describe above.   If you continue to have problems, please contact support with the service tag from your XPS system and explain the problem you are having.   They should be able to take appropriate action.

www.dell.com/.../SLN304347

0 Kudos
SonyHome
1 Nickel

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

Hi Brian B,

Thanks for the reply.

As I've indicated everything on my system is up to date. I've tried to download and install them again but it tells me I have the latest and install stops. Do I need to uninstall some things like Thunderbolt drivers and firmware from my laptop and reinstall?

I've tried to disable the wifi card on my XPS15 like someone suggested but I still saw the blank screen issue happen.

0 Kudos
Moderator
Moderator

RE: TB16 HDMI connected monitor goes blank for few seconds every few hours

Jump to solution

Are you going into airplane mode?    If so and still having problems, please send me a PM with contact information and your system service tag.

0 Kudos