Tap on touchpad moves mouse pointer up a few pixels, so click either misses target or doesn't register

I have a brand new Latitude E7470 (Windows 10 Pro) which has some good and some (surprisingly) awful bits, but so far the most surprising and frustrating is that when I tap the touchpad - which acts as a left click - about 90% of the time the mouse pointer moves a few pixels - maybe 10? - before the click event is registered. This doesn't sound like much, but it makes the touchpad at best incredibly frustrating, and at worst unusable.

To clarify: I'm moving the mouse pointer using the touchpad (which works pretty well). I position the mouse pointer over a clickable item - a link in a web page, the "x" to close a tab, a button, etc. - and then use the single tap motion, which should register the same as the left mouse button below the touchpad. And it does register that left click, but the mouse pointer visibly moves several pixels - most often up, but occasionally left or right or diagonally. As a result, the click event either doesn't register, or more likely the pointer isn't over the clickable component anymore so it's like I clicked above or beside it.

I've spent hours experimenting with this, including going back and forth between the new E7470, my ~4 year old Precision M4700, and Macbook Air, just in case this is something weird about how I tap. No matter how carefully (and unnaturally) I click tap on the E7470, the pointer moves. On the other two laptops the pointer never moves when I tap, and simply registers the tap/click event where the pointer originally was.

Also, the pointer does not move when I use the mouse buttons below (or above) the touchpad, only when I tap on the touchpad.

I've tried resetting the defaults in the Dell Pointing Devices app - I hadn't actually changed them myself, but I went through and clicked "Default" and then save for each page in the app - but that made no difference. I find that setting the tapping speed lower - Sensitivity->Tapping->Tapping Speed - seems to help a bit, but for smaller items like the close button on Chrome tabs, the pointer moves enough that it misses most of the time.

Any suggestions besides swapping out the laptop?

2 Replies

RE: Tap on touchpad moves mouse pointer up a few pixels, so click either misses target or doesn't register

Looks like 73 views of this post and no replies. I'm going to hope that means that my problem is not common, which suggests it's likely hardware. I'm having lots of other issues with the laptop anyway, so with luck if I swap the hardware this issue will go away.

1 Copper

RE: Tap on touchpad moves mouse pointer up a few pixels, so click either misses target or doesn't register

I was having this problem too, www.reddit.com/.../to...

I fixed it by manually installing ELAN drivers. N550JV uses touchpad made by Elan like other ASUS notebooks. Manually installing driver in device manager forces Windows precision touchpad to operate where you can get simple gestures etc. within the Windows settings. Single-tap cursor jitter is also gone completely!

So, all in all, it was bad software/driver suite (ASUS Smart Gesture) which caused this issue in the first place.

If your notebook uses Synaptic touchpad then you need synaptic drivers. Search for "enabling windows precision touchpad" and you will see. Like this one: www.windowscentral.com/how-enable-precision-tou...

edit: you need to uninstall all touchpad driver/software completely beforehand.

I Walk Alone