Highlighted
Presidium
1 Copper

Touchpad won't CLICK while a key is being pressed

Hey guys, My Dell Inspiron 15R running Windows 8 has has had a touchpad problem for as long as I can remember. Basically, when any key is pressed, the clicking function on the touchpad is disabled both while the key is pressed and for about 1 second afterthe key has been pressed. The latest driver update (11.3.5.4) fixed the <ADMIN NOTE: Substitute character removed as per TOU> Palm Rejection feature. With this update, when Palm Rejection is disabled, it allows for the cursor to move while/after a key is pressed, but actually clicking (whether it is with tapping or with the actual left-click button) is still not enabled, no matter how many different settings configurations I try from within Dell Touchpad settings.

If you want the quick version, here are things I've already tried:

  1. Updating my driver: it's up-to-date.
  2. Enabling/disabling Palm Rejection.
  3. Enabling/disabling tap clicking.

Please look into this for me. I truly can't afford to buy a mouse right now, and this fix would be very helpful. Thank you.

0 Kudos
1 Reply
ZellZoy
1 Copper

RE: Touchpad won't CLICK while a key is being pressed

Here's a sortof solution for you:

1. Open mouse settings.

2. Go to the Buttons section.

3. Select "Switch primary and secondary buttons" under Button Configuration.

Does this seem like it has nothing to do with your problem? Yeah, I just randomly stumbled upon it. Now, somethings to note:

1. This does NOT switch the left and right buttons under your trackpad, they'll still behave the same way.

2. The left button will now click normally while typing, but the right one will still be "locked".

3. This DOES switch the buttons on any external mouse you connect, you will have to disable the setting if using a regular mouse.

0 Kudos