Highlighted
Presidium
1 Copper

Touchpad won't CLICK while a key is being pressed

Hey guys, My Dell Inspiron 15R running Windows 8 has has had a touchpad problem for as long as I can remember. Basically, when any key is pressed, the clicking function on the touchpad is disabled both while the key is pressed and for about 1 second after the key has been pressed. The latest driver update (11.3.5.4) fixed the *** Palm Rejection feature. With this update, when Palm Rejection is disabled, it allows for the cursor to move while/after a key is pressed, but actually clicking (whether it is with tapping or with the actual left-click button) is still not enabled, no matter how many different settings configurations I try from within Dell Touchpad settings.

If you want the quick version, here are things I've already tried:

  1. Updating my driver: it's up-to-date.
  2. Enabling/disabling Palm Rejection.
  3. Enabling/disabling tap clicking.

Please look into this for me. I truly can't afford to buy a mouse right now, and this fix would be very helpful. Thank you.


P.S. This is an exact copy of my previous post almost 5 days ago. It had no responses from community members or any Dell Support technicians. I'm hoping this repost will run it across some new eyes and get just a little attention.