awi231
1 Nickel

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

Just letting everyone know, there is a firmware update to the thunderbolt, and a few other drivers. I downloaded all the most recent. I uninstalled and then rebooted, installed the each of the latest drivers, and then rebooted again. Takes time but it appears to be worth it. 

I too had many of the same issues everyone else had, looks like everything is solved. I had issues with a usb ethernet being dropped all the time. I think that is solved now. 

I also had the monitor issue with the TB15 dock going to a 4K dell display. It would work for a bit and then flash and come back or it wouldn't come back and go into power saving mode. Really annoying. I would have to switch to the laptop monitor, power of the secondary, turn it back on and switch the display mode on the laptop. It appears with the latest drivers and the new bio everything is solved. I'll report back if not.

0 Kudos
frost2112
1 Copper

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

I agree. Garbage configuration! Why haven't they fixed the USB C Thunderbolt port yet! This should be a simple firmware or driver update.

I have had every problem list here while using my TB15 with my 9550. New downloads fix some problems, but cause others. How could they release this product with so many bugs!?!?!?!?!?

PLEASE FIX THIS DELL!!!!!

0 Kudos
DSXDATA
1 Copper

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

Updates installed - current as of today. As others ave said, there is some improved stability - but only with a single monitor. If I add a 2nd monitor, it re-syncs about every five minutes or so. Not quite usable yet.

0 Kudos
birdie-san
1 Copper

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

Exact same problem here. I updated all drivers, including BIOS and Firmware but it's constantly disconnecting my external monitor when I'm connected through the TB15 dock. Please, please make this a priority to get fixed.

Randle81
1 Copper

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

Similar issue here. I get the problem when either using a usb-c to hdmi connector or a hdmi to dvi connector. After a period of maybe 40-50min it will disconnect the external monitor and I will need to unplug / plug in to get it to work again. I hoped the new firmware/drivers/bios would fix the issue... it didn't.. Surely this issue shouldn't be so hard for Dell to fix!

0 Kudos
ubus
1 Nickel

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

Club 3D ucb-c / thunderbolt 3 to hdmi 2.0 adapter  no problem connecte to 4k tv (panasonic) 60hz

0 Kudos
Muzzer
1 Copper

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

Updated my BIOS on Monday with the new version. Not convinced it's actually improved much. I still find that my second external QHD monitor (the one connected through the USB-C) often doesn't come up from fresh boot unless I restart, even if I unplug and reconnect the USB-C. Trying to use CAD often causes really bad mouse stuttering which requires a reboot to cure. And since the BIOS reflash, I've found that it often gets stuck at the BIOS screen ("DELL") until I kill it and make it try again. 

In order to get expansion into these ultrabooks, they have had to do away with the proper docking port and rely on these Displayport devices. Seems that the Displayport salesmen did a good job on Dell but now their engineers are struggling to deliver a stable solution. Never mind, each XPS shipped makes Displayport and their salesmen a nice extra bit of profit.

Have to say, my previous Dell ultrabook (XPS13) required an external USB3 dock which was also really flaky. Displays with a mind of their own, stuttery mice etc. Seems familiar? That almost certainly had Displayport inside that too although it was sold by a reputable(?) 3rd party like Kensington(? IIRC). As this XPS13 was about 3 years ago, it doesn't seem that Displayport have a robust product line - or a robust development environment. They seem to think if they keep throwing it at the wall it will eventually stick. Well, not so far....

0 Kudos
DSXDATA
1 Copper

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

I received a video driver update yesterday via Dell's driver update servivce and applied it. It appears as if I can now use a second monitor if I wait until the machine is finished loading all of the startup processes and services before I plug it in. If I leave the second monitor connected and power cycle the machine - the result is a random series of interface resets where one or both monitors will black out and the machine will emit a beep indicative of a PNP driver being loaded. I presume the display driver is crashing and then being reloaded. The end state was a machine that - interestingly - would not respond to a restart or shut-down command. I had to force the machine off by holding down the power button. 

0 Kudos
jigawot
1 Copper

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

After the new BIOS firmware was released a few weeks ago and I saw a few people post on this forum that things were looking better, I decided to go ahead and try purchasing the Dell Thunderbolt Dock.  I eagerly plugged it in and my secondary and tertiary monitors came up and Windows installed the devices.  So far, things were working great.  I did a reboot and when I got to the log in screen, both of my external monitors were just blank.  I logged in and still nothing.

I contacted Dell technical support and after uninstalling and reinstalling the drivers the monitors connected again until I rebooted.  The technician tried cycling the drivers again and we had the same results at which point he said the next step was to reinstall Windows and then install the drivers in the right order.  I'm sorry, but that is totally unacceptable to me.  This laptop is less than 30 days old -- I should not have to reinstall my operating system to get a peripheral to work.  Not only is this unacceptable, but it is flat out unprofessional.  Call me skeptical, but I have my doubts that resetting my PC is going to make any difference and I can't afford the downtime especially if it is all for naught.

1. Has anyone else had the same symptoms I had?  (Working for until a reboot and not detecting the hardware from the Windows login screen?)

2. Has anyone tried doing a Windows reset to see if installing the drivers "in the right order" actually makes any difference?

0 Kudos
64dude
2 Bronze

RE: Trouble with XPS 15 9550, USB-C/Thunderbolt 3, and external monitors

I'm having better success with the TB15 by:

  • Turning off Switchable graphics (I have a Precision 7710 w/ ATI)
  • Installing latest firmware, drivers in prescribed order (other threads here on TB15)
  • Powering the laptop directly w/ its adapter, with the hub w/ its own adapter (my TB15 suddenly is only being detected as a 65w power supply)
  • Only driving monitors with the TB15, nothing else (no USB or ethernet)

Its a workaround, but at least I can now drive three external monitors as I wait for a replacement TB15 which is now on back order. Looking for a more reliable TB hub that can drive three monitors in my case.

64dude