jakethegreycat
Not applicable

Upgraded to windows 7: built in mic doesn't work

Hello,

I have a dell XPS M1530 laptop and have recently upgraded to windows 7. Unfortunately I discovered today that the built in mic no longer seems to work. Is anyone else having this problem? If so has any1 found a solution? If more specs are needed I would be happy to provide them, any help would be appreciated. Thank you.

0 Kudos
34 Replies
ptruong82
Not applicable

Re: Upgraded to windows 7: built in mic doesn't work

Hi,

 

I just recently upgraded my m1530 to windows 7 and I also found out i have the same issue when tried to use Skype.  I went to the sound device manager and checked to see if everything was working properly and the mic was not muted.  I went to google and tried to find a solution for the problem and it seems that there are other users are facing the same issue.  It seems that the default windows 7 drivers don't handle built in laptop microphones well.  I'm also still searching for a way to resolve this issue.

0 Kudos
Shermonno1
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

Yes. I am having the same problem with my Dell XPS M1530 and still trying to figure out a solution. Do let me know what you find. I have read that you may need to install the windows vista drivers in order for some hardware to work but I do not know how feasible this ans. is.

Shermonno1

0 Kudos
giorge
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

It happened to me too. The solution is very easy though. Just INSTALL WINDOWS VISTA SOUND DRIVERS available at you Dell support pages. I did it and now it's working as a charm. Even the enhancements for the mic is working too.

By the way, I got a M1530 with Windows 7 64-bits installed (so I got the Vista 64 drivers).

0 Kudos
Shermonno1
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

This is a bit strange because I have a XPS M1530 with a 32 bit OS so I installed the Vista 32 bit drivers and still nothing. I have also tried removing the drivers and reinstalling them again and sometimes get the message "There is no file to install". Nothing still....

Any ideas?

Shermonno1

0 Kudos
Shermonno1
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

So I figured it out finally. Went to Control Panel then Devices manager.

Click on the Sound, video and game controllers option

 then right click on the tab that opens below and select the current driver and then select uninstall.

Go to Dell drivers and downloads page and find your system type and operating system.(In this case it should be Windows Vista OS either 32 or 64 bit depending on your system since there is no option for Windows 7.)

Select audio and then select Sigmatel -Driver.  This should take you to a download page and then download this driver (preferably in Explorer). Then install this driver by following the procedures then immediately reboot when prompted.

It should work after this…Hope this helps.

 

0 Kudos
okhandan
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

I have the same problem with my xps m1530. the built in mic doesnt work on windows 7 64x. I tried installing the vista 64x drivers but I get this error on the install:

 

ExitError:Error=Device Object not present, restart the system and run setup again.

 

I tried running in vista mode, still no luck. any help?

0 Kudos
Shermonno1
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

Try following the same instuctions I suggested in the prior response but only doing it for the Vista drivers for sigmatel. REMEMBER, you must UNINSTALL the drivers you have there before you install the new one.

Control panel/ devices manager/ sound, video and game controllers and then uninstall...then follow the remaining instructions.

Good luck.

0 Kudos
okhandan
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

Every time I uninstall the drivers, windows 7 prompts me to reboot. Upon reboot it automatically installs its own default drivers!! How do you stop it from installing default drivers?

0 Kudos
okhandan
2 Bronze

Re: Upgraded to windows 7: built in mic doesn't work

even after uninstalling the audio drivers from device manager i still get that error message when trying to install the sigmatel dell drivers.

0 Kudos