1 Nickel

Vostro 1014, can't get it functional


So I bough the Vostro 1014, that came with the Ubuntu.

I wiped the HDD clean, and I installed my Win XP. But now I can't make it functional.

First as default, I cannot connect to network/internet. So I used my desktop to download all the drivers from dells site at



But besides the Chipset Intel-Driver and Touch pad, I can't install Anything else since I keep getting errors. Not even the network so I could maybe let Windows download the updates from the internet.

Especially for the network drives, it says my operating system is not supported, yet I was under Windows XP when I searched for my drivers.


As of now I have the following devices as unknown.


Base System Device

Ethernet Contrller

Network Controller

PCI Device


And the GM45 failed to install propely as it couldn't find several components during setup.


Please help?


0 Kudos
4 Replies
9 Rhodium

Re: Vostro 1014, can't get it functional

You must install drivers in a specific order.  That process is detailed here:



0 Kudos
1 Nickel

Re: Vostro 1014, can't get it functional

Thank you, I will try that. But for some reason the link says "The chosen document is not currently available."

Did they moved the link?

0 Kudos
1 Nickel

Re: Vostro 1014, can't get it functional

Ok, link is working again.


I am however stuck at the first step, installing the DSS

I press Install, and nothing happens when I run it.


I have installed The chipset after

After I install Intel storage, says I need framework 3.0 (can't get it since I can't conenct to internet/network)

After I tried audio, I get an error saying Driver Installation Failed: Could not find the media device for this driver.

After I tried video adapter, install went fine this time for video.

After For Network Interface Card, I think it's the realtek ethernet, so I run that (there is no NIC for download). Instalation apparently worked

Could not find a Dell quickset to install

After I tried Wireless, the QMI (since the specs says the vostro has a b/g/n, I chose to install QMI and not the Wireless 1397 b/g)


However after all this, I still have a unknown device called Base System Device

I have a PCI Device with a yellow ! saying it has a problem

And a bunch of yellow ! under USB Controllers, got 8 yellow ! related to Intel ICH9 family USB.


Also my Wireless enable/disable button (fn + F11) does not work.


Thank you for helping me and waiting eagerly for more input Smiley Happy

0 Kudos
1 Nickel

Re: Vostro 1014, can't get it functional

So could anyone please help me out with the remaining problems?


I cannot install the sound. I get the Conexant Audio under Win XP (I have set my service tag in driver download) but I get that problem " Driver Installation Failed: Could not find the media device for this driver."


Other than that, what other dell drivers do I need to download for my USB (the 8 in yellow), the PCI Device under System device and the unknown base system device.

0 Kudos