2 Bronze

Vostro 5480 BIOS update crashed, now bootloops


I recently tried to update the BIOS of my Vostro 5480, but the update froze in the end. I waited 1 hour but Windows was still frozen, so I decided to turn off by holding the power button.

Now I can't boot anything else, as it will always goes to the BIOS screen with the message below, it waits 5 seconds and then reboots itself.


Unfortunately, it's not under warranty anymore.

I searched Google for solutions, but none helped me. I got the latest BIOS file (can't find old ones), and tried putting the files inside a flash drive (.exe, .hdr and .rom files) with some random and suggested names, but I couldn't get it right.

Is there anything else that I can try?

Thank you in advance

0 Kudos
1 Reply

RE: Vostro 5480 BIOS update crashed, now bootloops


Welcome to our community,

We are sorry to hear that you are facing issues with the system after the BIOS update. You’ve reached the right department, we'll surely try and assist you. We appreciate you for sharing the images. We’d suggest you to run the hardware diagnostics, so that we can isolate issues between hardware and software.

Please follow the below mentioned steps to run the hardware diagnostics, please share the error code and the validation code if you find any.

1. Restart the computer.
2. As the computer boots, press < F12 >.
3. When the Boot menu appears, highlight Diagnostics option and then press < Enter > to start the Dell Diagnostics.

4. Press the < Enter > to continue Diagnostics.

You can also click on the link which is a video that shows steps to run the diagnostics.

0 Kudos