2 Bronze

WD15 Dock not outputing video signal

Hardware being used:
- WD15 USB-C docking station
- Latitude 7280 or Latitude 7480

When laptop is connected to the WD15 docking station, it will consistently not output video to an external monitor. It's trying to simulate end user's taking their laptop to a meeting and coming back and docking back up with the lid closed. Our laptops are configured to "Do Nothing" when the lid is closed. I've reduced this down to just a laptop, docking station and a monitor connected either by VGA or Mini-DP or HDMI. When attempting to dock, it does not consistently output video to the external monitor. Sometimes I'll have to disconnect/reconnect the docking cable multiple times before video will output on the external monitor. 

And thrown in the mix is sometimes it will kill ALL USB ports on the docking and on the laptop. The only way to restore USB port functionality is to shutdown the laptop and turn it back on again. We experienced this USB issue 6 months ago and found it was due to a bad Realtek USB 2.0 driver for the docking station. Installing an older version of that driver fixed the issue at that time. Since it's resurfaced with this, we've tried the driver fix, and it no longer resolves it.

I've tried reaching out to Dell support, but their only solution is to keep replacing the WD15 docks, but it doesnt resolve anything as issue occurs on replacement docks they send. This happens on multiple of our 7280 & 7480 laptops that have been deployed to users. With all the troubleshooting I've done, my team and I feel that this HAS To be on an hardware level that Dell is not coming forward about.

Here are ALL the troubleshooting steps I've performed, ALL of which have failed.
- Update BIOS
- Update WD15 Dock Firmware
- Update ALL Dell Drivers via Dell Command Update
- In BIOS \ Dell Type-C Dock Configuration, Enabled "Always Allow Dell Docks"
- Reverted "Realtek USB 2.0 Audio" driver back to 6.3.9600.50 which previously resolved USB issue 6 months ago
- Tried with single monitor connected directly to VGA
- Tried with single monitor connected directly to Mini-DP
- Tried with single monitor connected directly to HDMI
- Swapped w/known good monitor
- Changed Power Scheme to "High Performance" in Power Options
- Changed "USB Selective Suspend Setting" to disabled in Power Options
- Adjusted resolution (higher & lower settings)
- Adjusted monitor frequency (60Hz & 48 Hz)
- Swapped w/known good docking station
- Tried w/replacement docking station from Dell
- Reimaged w/non-altered Windows 10 w/base drivers
***This image was downloaded direct from Microsoft to eliminate our custom Company OS image
- Downloaded Intel 650 Graphics Driver from Intel site

Anyone have any other Troubleshooting steps I've overlooked???
Dell Forum Techs, I'd LOVE to hear your input regarding this issue.

0 Kudos
3 Replies
7 Gold

RE: WD15 Dock not outputing video signal

Wow, I have a 7480 that I've been using with a WD15 dock regularly for months and it's always performed flawlessly, so I'm really surprised to see you having this issue with multiple systems and docks.  You've already tried basically everything I'd have suggested, but just to verify, when you have the dock connected, you do NOT also have the separate AC adapter connected, correct?  I'm not sure that could cause this type of behavior (in fact I admit it's a long shot), but I know that's not supposed to be done.

Also, what is the Realtek USB 2.0 driver you're referring to?  The only drivers involved for the WD15 dock are Realtek USB Audio, Realtek USB Ethernet, and (indirectly) the GPU driver.

Lastly, what OS are you testing with? (UPDATE: Sorry, I see it's Win10.  Missed that originally.)

0 Kudos
7 Gold

RE: WD15 Dock not outputing video signal

One more question: Are you using at least 130W AC adapters with the WD15 docks?

0 Kudos
2 Bronze

RE: WD15 Dock not outputing video signal

- Regarding using at least a 130W AC Adapter, Yes. All troubleshooting has been with multiple of the original power adapters that came with the docks. In addition, I've even tried w/130W & 180W docks direct from Dell. At all times, the AC Adapters have been directly plugged into the WD15 Docking station as it should be.

- Regarding OS, Yes Windows 10. Issue has occurred across multiple builds, but currently on 1703.

- Regarding USB2.0 driver. When the WD15 dock is plugged in, In Device Manager it appears under "Sound, video and game controllers". Under that category it has the following: Intel (R) Display Audio, Realtek Audio, and Realtek USB2.0 Audio.

0 Kudos