Jobber77
1 Copper

WD15 dock + XPS 15 9560 = lags

Hi everyone

I have XPS 15 9560 and WD15 dock packed with all latest drivers and firmware updates, available on Dell support pages.

I read&implement all available trobleshooting post recomendations on dell website and all around the google 🙂

What i understood - i'm not alone with my problems.

I have following issues: 

Mouse and keyboard which are connected directly to laptop - starts to lag (mouse - complete frize or slow move, keyboard - huge ping in typing) when laptop expirience any kind of load (example - oppening of microsoft office apps)

Anyone have any ideas how to fix it? 🙂

0 Kudos
5 Replies
Community Manager
Community Manager

RE: WD15 dock + XPS 15 9560 = lags

Hi Jobber77,

Thanks for posting.

Apologies that your system is not working as expected.

Here is some information from the Dell Knowledgebase you may find helpful.


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
samos1111
3 Zinc

RE: WD15 dock + XPS 15 9560 = lags

Such issues with devices connected to the dock were present over a year ago and then later a couple of months ago with certain laptop BIOS versions. Are you sure you've got the latest BIOS?

Other kinds of related issues seem to be related to some sort of interference between wifi and USB (maybe drivers, maybe USB cable&connector shielding). For test, you can try disabling the wifi/BT card in the Device Manager.

0 Kudos
Jobber77
1 Copper

RE: WD15 dock + XPS 15 9560 = lags

Hi, samos1111

Thank you for reply.

Yes, i have latest available Bios version for XPS15 9560 - 1.5.0.

I even tried to install older ones to fix issue. Do not help.

I tried to use airplane mode, do not helps. I will try to switch them off in Device Manager as well today and check again.

I want to mention, that laggy mouse and keyboard is connected directly to notebook. They start to lag only when dock is connected.

0 Kudos
Jobber77
1 Copper

RE: WD15 dock + XPS 15 9560 = lags

Hi, DELL-Robert P

Thank you for reply

That is not helpful. I tried everything from that list.

0 Kudos
Community Manager
Community Manager

RE: WD15 dock + XPS 15 9560 = lags

Please contact tech support for further troubleshooting and possible resolution.

You can contact Tech Support at 1-800-624-9896  or 1-800-288-4410, or you can initiate a chat session http://dell.to/2v4snVm


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos