Highlighted
awasen
1 Nickel

Windows 10 Bitlocker code required every time after BIOS upgrade on XPS 15 9560

Jump to solution

I had a lot of issues with the screen blinking/flickering on/off when removing the laptop from the WD-15 dock and read that the new BIOS upgrade would fix this issue so I went ahead and upgraded the BIOS.

I installed "DellDockingStationFwUp_1.0.0.8_20161220_WD15.exe" and "XPS_9550_1.2.21.exe".

I added Bitlocker protection the first thing I did when I got the laptop about a year ago and it has been working fine.

After this upgrade (with or without) the dock attached I get the Bitlocker code prompt at every start of the laptop.

I can't seem to roll back the FW upgrades as the installer tells me I have a newer version installed...

0 Kudos
1 Solution

Accepted Solutions
awasen
1 Nickel

RE: Windows 10 Bitlocker code required every time after BIOS upgrade on XPS 15 9560

Jump to solution

Thanks, I did that, Robert, and no go... 😞

I contacted Dell support and they want to replace the MOBO in the laptop but as it is 15 months old they won't do it on warranty so I'll probably go and buy a HP instead...

0 Kudos
5 Replies
awasen
1 Nickel

RE: Windows 10 Bitlocker code required every time after BIOS upgrade on XPS 15 9560

Jump to solution

After searching and checking I found that I no longer have any compatible TPM according to Windows.

(Win 10 Enterprise 64bit Build 14393)

Looking in the BIOS there is no setting for TPM anymore so then I found a way to rollback BIOS FW.

It was by shutting down, unplug the power plug and then keep CTRL+ESC pressed while plugging in the power plug. That brings up a prompt where I could do a rollback and after that tehre still is no TPM in BIOS. I run the same again but this time I chose to reset the BIOS settings, still no TPM!

I still have to give the Bitlocker key at every startup and to top it off the laptop no longer goes to sleep when the lid is closed, it shuts down even though the settings is to "sleep".

This of course means that every time I carry it around I have to add the Bitlocker key when picking it up.

Our corporate network requires Bitlocker so I can't use the laptop without bitlocker in the domain.

Any suggestions?

0 Kudos
Community Manager
Community Manager

RE: Windows 10 Bitlocker code required every time after BIOS upgrade on XPS 15 9560

Jump to solution

Hi awasen,

Thanks for posting.

Apologies for your system not working the way you expected.  Here is some information you may find helpful: http://dell.to/2nUoPlH


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
awasen
1 Nickel

RE: Windows 10 Bitlocker code required every time after BIOS upgrade on XPS 15 9560

Jump to solution

Thanks Robert, however my problem is that the TPM option is missing in the BIOS. It is gone...

I've tried to downgrade the BIOS version but the TPM option is not there in Security section where it should be...

0 Kudos
Community Manager
Community Manager

RE: Windows 10 Bitlocker code required every time after BIOS upgrade on XPS 15 9560

Jump to solution

awasen,

If you followed #4 from the information I sent:  

4. Check your Hard Disk Drive Boot Sector
 

If the error a required TPM measurement is missing persists, the next step is to attempt recovery of your hard drives boot sector.

Windows 7, 8 and 8.1 could install on a Legacy BIOS using MBR. However Windows 8, 8.1 and 10 were designed to install on the UEFI BIOS using the EFI bootloader and GPT.

Try encrypting using BitLocker again and if your issue with the same TPM error continues past this, then please contact technical support for further help.  Thanks


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
awasen
1 Nickel

RE: Windows 10 Bitlocker code required every time after BIOS upgrade on XPS 15 9560

Jump to solution

Thanks, I did that, Robert, and no go... 😞

I contacted Dell support and they want to replace the MOBO in the laptop but as it is 15 months old they won't do it on warranty so I'll probably go and buy a HP instead...

0 Kudos