Laptops General - Read Only

Last reply by 08-01-2017 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13/15 9530, 9550, 9630 can only reach Thunderbolt 2 speeds over Thunderbolt 3 port.


I myself own an XPS 15 9550 and noticed that I was not getting the full Thunderbolt 3 speed
over it's Thunderbolt 3 port. I expected speeds around 2700MB/s, because of the overhead with
the theoretical gross speed of 3870MB/s, but I only ever got 1400MB/s out of it.

I did some digging and found out that none of the XPS notebooks with Thunderbolt 3 are even
able to achieve the full TB3 speeds, because they are only connected with two PCI Express lanes (x2.3).

You can read more about this on the following links:

Dell Subreddit Post
Chipset Digging on Forum

Thunderbolt 3 and the promised speeds were the MAIN REASON I even bought this notebook.
I feel very cheated here.

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze

The number of PCI lanes connected to the Thunderbolt 3 port has nothing do with the speed of the Thunderbolt 3 port itself. I know this sounds counter intuitive, but let me explain.

Each PCI lane provides 8Gbit/s of bandwidth. This means that even with 4 lanes, the maximum possible bandwidth over PCI is 32Gbit/s, much lower than the 40Gbit/s that Thunderbolt 3 is capable of.

Instead, Thunderbolt 3 acts as a single interface for a number of different protocols, PCI-e being only one of them. The Thunderbolt port is also connected to a separate set of 8 DisplayPort lanes which provide 34Gbit/s worth of bandwidth to drive two 4K displays at 60Hz. The Thunderbolt port is able to draw bandwidth from both the DP and PCI lanes at the same time (with priority given to DP), so long as the total bandwidth being used at any one time stays below 40Gbit/s. This is where the 40Gbit/s comes from - not the PCI-e bandwidth.

Yes, having only 2 PCI-e lanes connected to the TB3 port does mean there is less PCI-e bandwidth available, however it does not limit the maximum speed of the port itself, which is still capable of delivering 40Gbit/s when used for DisplayPort data, something which would be necessary to reach 40Gbit/s even with 4 PCI-e lanes.

Please see the document for a more detailed explanation:

View solution in original post

Replies (19)
2 Bronze
2 Bronze

I also own a 9550 and feel the same :(

7 Thorium

Hi splitframe,

Thanks for posting.

Here is some information you may find helpful.

2 Bronze
2 Bronze

Hello Robert,

I appreciate the answer and the information provided, but fail to see

how it helps in my case.


7 Thorium

Have you ruled out a software issue in any way? There are four basic ways to accomplish this.

You can restart the PC with the Thunderbolt device plugged directly to the Port on it's own. Once the PC has restarted,
install the driver that came with the device. If it still doesn't work, then you will need to proceed with one of the
remaining options. .

You can two way swap your HDD (Hard Disk Drive) with one from a similar working system and see if the fault follows
the HDD to a new machine or if the issue stays with your system? Please follow your User Guide for instructions on
removing any hardware parts as the steps change from system type to the system type or you can search on our support
site using terms such as "your PCs model type", "CRU" and "removal" to find a guide specific to your machine.

You can boot from an Ubuntu Live CD (Regardless of the the operating system currently in use on the PC.) and check to
see if you experience the same issue in another OS. Ubuntu live CD's allow you to boot the OS off the CD without
installing it on your Hard Drive. You can download an ISO of the CD on the Download link below. Tap rapidly at the
F12 key when the system boots to the Dell Splash screen and choose the CD/DVD drive option from the boot once menu
that appears.

Ubuntu ISO Download Link.External Link

You can run a factory restore or reinstall your Operating system.

Caution: Carrying out option iv. would be done as a last resort and only done if one of the other two steps couldn't
be done. You MUST back up all data before carrying out this procedure - if you do not data WILL be lost. Any operating
system reinstall or factory restore involves formatting your Hard Disk Drive (HDD). Please refer to the guides on the
Windows portal for further information on these procedures.

2 Bronze
2 Bronze

Hello Robert,

thank you for pasting the content of the link you posted earlier again.
Like the link before it did not really help me.
To humor you, yes, with the exception of using Ubuntu Live I, indeed, did all
of the above and more. I also checked multiple BIOS/FW versions like 1.1.19
1.2.0, 1.2.14 and 1.2.16. Furthermore I tried my Akitio on another notebook and
reached full speeds there with the SSD as well as with the GPU.
I did these tests before I knew that it is indeed  a Hardware issue.

If you look at this excerpt from the documentation of the chipset that
the XPS 15 uses you will see that if a device is mounted on PCIe Port #15
it is only given two PCIe lanes, if a device is mounted on PCIe Port #13 it can
use up to four PCIe lanes, the two from Port #13 and #15 combined.
Now if you either look at the screenshot from HWInfo64 here or the
BPD file here ( PCI Scope report ) you will see that the Thunderbolt 3
controller is indeed mounted on Port #15 which on its own is not able
to reach 32Gbps (x4.3) speeds, it only reaches 16Gbps (x2.3) which
corresponds to the results I got in all benchmarks or speed tests I made.
But I am sure you knew most of this as you read through the links I provided.


7 Thorium


At this point, the only alternative I can offer is to contact Tech Support for additonal troubleshooting, repair, and possible replacement.  Thanks.

2 Bronze
2 Bronze

Is there any update ? Because this problem surely affect to all XPS owners.

2 Bronze
2 Bronze

Would also like to here from Dell about this.

Not applicable

I also have this problem. In the offer wrote up to 40gb/s Thunderbolt 3.

Latest Solutions
Top Contributor