Laptops General - Read Only

Last reply by 09-20-2017 Unsolved
Start a Discussion
Not applicable

XPS 13 9360 (2017 7th Gen i7 + TB 16 + P2415Q = A literal nightmare.

Let me preface that I have zero issues with the XPS 13 9360. It's fantastic, QHD touch screen with the i7 makes everything super speedy and it looks gorgeous. I was replacing a 7-year-old HP so this was leaps and bounds better what I had before.

So naturally I want to get 4K going on another monitor for work as I had previously worked with another monitor as well but, XPS doesn't have any display inputs (which isn't a big deal).

I looked around for docks and other things I can use to get a 4K external up and running and found what I thought was the perfect combo.

A TB16 dock which has all of the features I want and need for my laptop. And a P2415Q which is a gorgeous dell 4k monitor. So mind you, everything about my set up is ALL dell. I have no other manufacturers in the chain here.

So the TB16 is already getting absolutely horrible reviews across the board, mainly the flickering issue and USB/Ethernet not working. But I figured it was just people over-reacting and not knowing what to do or troubleshoot issues.



When I set everything up, the dock worked perfectly. Ethernet worked, USB ports worked, etc. Seemingly out of the box everything was great (Dell even updated all the drivers I needed). Then I decided to finally connect the 4k monitor. Here's where it went downhill....

I had a BRAND new 1.2 Displayport to Displayport cable (not mini) to take full advantage of the 1.2 version. I had heard the Displayport to Mini Displayport doesn't work too well so I wanted to be sure this would work well. 

When I connected the monitor to the dock, it flashes for a few seconds then shows the beautiful monitor. Full resolution (3840x2160) at 60Hz, which is pretty decent for doing office work and even print/video work if you needed to.

Eventually as I was working on that monitor the screen would flicker, which is absolutely BIZARRE considering I paid close to $2k for this whole setup. And it would continue to flicker. Usually when I opened a program, clicked on a prompt, etc. the flicker still happened. 

Sometimes it flickers a few times and P2415Q will say "going into power saving mode" and will not come back on unless I...

A.) Turn off the monitor and turn it back on.

B.) Unplug the monitor from the dock and reattach it

C.) Completely restart my computer.

So I can pretty much say goodbye to doing ANY real work on this monitor as it's not even usable at this point. It just flickers until it shuts off. If I just leave it open and do minimal work on JUST the XPS screen, it's fine. There's usually no flickering. But the second I do work on the monitor, it flickers until it stops working eventually. Usually within 20-30 minutes it'll stop working.

Here's the list of things I've done to try to solve this issue and it's still not solved correctly.

- Updated every single driver for my XPS 13

- Updated every single driver for my TB16

- Installed every driver for the P2415Q

- Tried using my XPS 13 with a power cord attached instead of just the dock as power.

- Disabled my WIFI via windows 10 AND via the driver manager. Neither worked.

- Tried a mini DP to a DP cable that came with the monitor

- Tried a DP to DP cable that was a third party cable (still 1.2 compliant)

- Attempted to look up the Service Tag & Express Service Tag, neither of which were found on Dell (Thanks Dell!)

You get the point. I've every single official and non-official fix that anyone has come up with as well as a few of my own and I cannot get this working correctly. T

he only thing, and I mean ONLY thing that seems to work correctly 99% of the time is switching MST (Multi-Stream Transport) to Primary. But, when you do this you are basically forced to use 30Hz instead of the full 60Hz.

So essentially it's going from a speedy response to have a cursor that seems like it's being dragged in mud.


The TB15/16 issue is STILL not fixed. Even with their top-of-the-line XPS 13, it still fails spectacularly. I'm using ALL DELL EVERYTHING and it STILL doesn't work. 

How can I make this work, Dell?


Replies (3)
7 Plutonium

Just as a simple variable isolation exercise, the factors at play here are the PC, the TB16, and the display.  So you wouldn't happen to have any of the following would you?

- Another DisplayPort 1.2-enabled system (preferably another model that has native DisplayPort output) with which to test that display

- Another 4K @ 60 Hz display (preferably another model) with which to test your system and TB16

- Another TB16 with which to test your system and display

Another way to rule out the dock as the culprit would be to test a USB-C to DisplayPort cable/dongle, or even a USB-C to HDMI dongle if that display can accept 4K @ 60 Hz over HDMI (not all displays can).  USB-C when used with a DOCK is limited to 4K @ 30 Hz because in that scenario, the USB-C port is being asked to carry video and USB traffic simultaneously, but if you're using the USB-C connector solely for video using one of the cables/dongles I've just described, you can get a full DisplayPort 1.2 connection out of it and therefore get 4K @ 60 Hz.

7 Plutonium

In addition to the above, I'm not sure how recently you updated all of those drivers (and I'll assume that when you say drivers you're also including updates to the BIOS, Thunderbolt software, and Thunderbolt firmware?), but the XPS 13 fairly recently got a new BIOS release and even more recently got an Intel GPU driver update.  The BIOS update (2.2.1) was intended to fix some USB device instability issues with the TB16, and I'm not sure what the GPU update fixes since the release notes don't say anything useful.

7 Plutonium

Last thought for the evening: In addition to my 2 posts above, you wouldn't happen to be using Citrix, would you?  If so, Citrix has an article about blanking/flickering issues on 4K displays, including a fix:

Latest Solutions
Top Contributor