PartiallyRed
2 Bronze

XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

I have the latest BIOS (1.2.3) and audio driver update (7989) and am having this problem. Not sure why. I can end the Service Application and the CPU consumption stops, but this makes it such that the Waves MaxxAudio software can't detect a headphone being plugged in. 

The huge CPU consumption only occurs when I'm using the internal speakers. No problem with CPU consumption if the headphone jack is used normally.

EDIT: I found one way to trigger the problem. USB audio is causing the problem. I can reinstall all the DELL audio drivers and it would work well until I plug in the first USB audio device. Then it starts messing up whenever I use the internal speakers regardless of whether or not I have a USB audio device plugged in. My headphones can't be detected at all after this.

40 Replies
Saltgrass
5 Rhenium

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

Mine doesn't seem to do that.  Very little difference between external speakers and internal speakers.

Perhaps check the settings, namely enhancements, to see if there are differences in settings which might be responsible.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
0 Kudos
PartiallyRed
2 Bronze

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

Changing the settings don't seem to do anything. I think at this point it's just easier to uninstall the Waves software.  

0 Kudos
PartiallyRed
2 Bronze

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

.

0 Kudos
PartiallyRed
2 Bronze

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

@Saltgrass, I tried plugging in another USB audio device today (the other day it was a microphone, today it was a webcam) and the problem resurfaced. I now have to reinstall the drivers again.

Try plugging in a USB webcam and then unplugging it. This would cause the Waves MaxxAudio service to go from about 4MB of RAM use to about 12MB of RAM use. Then, it will start consuming 30% of CPU whenever audio is played. A detailed inspection using procmon shows that the Waves software is constantly quering the registry for audio streams.

This could be a driver issue on Realtek's end or it could be an issue on Dell's end (could be the new BIOS update that did some audio changes that did this).

0 Kudos
Saltgrass
5 Rhenium

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

I will have to check your comments today and will get back later.  There are two Waves services and an audiodg.exe.

I think the WavesSvc64.exe is involved with playing the music and the WavesSysSvc64 is involved with the audio Popup.  But right now I don't see much out of line with what I would have expected.

When you plug in the Webcam, the system has to change the default microphone and set up drivers for it.  That process accounts for some of the initial activity.  On my system, McAfee also accounts for quite a bit of the initial activity.  After a while, that initial activity calms down and the system returns to normal.

Removing the webcam also does not seem to cause a great disturbance.  The next time it happens, go into the Task Manager and select the Waves service, right click and select End Task.  Let me know what happens but the music playback should not stop.

First attachment, no music .. second with music

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
0 Kudos
Saltgrass
5 Rhenium

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

I was also wondering why you were using the Waves MaxxAudio designation.  Then I realized if you start that app, it does use more memory and probably CPU cycles because it is a User Interface.

For clarity, you are not starting the App during these tests.  You are just going to the Hidden Icons on the Task bar and selecting to open the User Interface when necessary and closing it afterward?

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
0 Kudos
Codster
2 Iron

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

I have a very similar issue. I have a Dell XPS (9360), BIOS (1.2.3), and Realtek Audio Driver (7989).

I have nothing connecting via USB or anything. I have a Bluetooth mouse and that's it. Whenever I start a Skype Call, or Hangouts Call (no one needs to answer), the "Waves MaxxAudio Service Application (WavesSvc64.exe)" jumps to 30% CPU usage. Everytime this happens, very easy to reproduce.

I beleive it is related to my Microphone becoming active. I can play sound from the internal speakers and everything is fine with the service. But when the microphone acitivates with the hangouts, or skype call, the cpu jumps to 30%. I can record on my Mic in (Voice Recorder) and it doesn't jump... But if I go to

onlinemictest(dot)com, and allow my mic the service jumps to 30% again. And that is only using my mic.

In the Waves MaxxAudio Pro Application, I've disabled everything under the "Voice" stuff. It still does it. I can disable the "Waves MaxxAudio Service Application" from the startup under Task Manager, but then the Popup doesn't work with my headphone jack...

Is there anything I can do? It's only annoying when I am playing games and Voice Chatting with my teammates... having that take 1/3 of my CPU lags up the game...

Does anyone else see this Service jump to 30% when in a Skype or Hangouts call on their Dell XPS 9360? Or is it just me?

0 Kudos
Codster
2 Iron

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

Sorry for the double post... I see what you mean when the first poster said it only happens when the internal speakers are used. But I do not believe it's related to the speakers.

I am not playing any sound. I just go to onlinemictest(dot)com, and test my Microphone, and the service will jump to 30%. (Again no sound is playing from my speakers).

Now if I plug in headphones into the Audio Jack. Then go to onlinemictest(dot)com, (again no sound is playing from my headphones during the test, just microphone), then the service is normal. The mic is still recording.

If I unplug the audio jack while still on that site, the Service jump to 30% as soon as the Headphones (which are not in use) are disconnected from the Audio Jack....

Definitely not normal behaviour... Anything I can do to fix it? Is Dell on top of this? Both pictures are running the online mic test (and no other sounds/mics). One with the headphones plugged in, one without.

0 Kudos
Saltgrass
5 Rhenium

RE: XPS 13 9360 - "Waves MaxxAudio Service Application" consuming 30% of CPU while on Internal Speakers

I will be doing some more testing during the day to see if my system, which is not a 9360, will duplicate what you or the OP are showing.

But for now, the difference between the onboard system and a headset might be the stereo microphones with the onboard system.  It might take more processing power.  Being online might also open possibilities the sound is being used for other things beside just what you think it is.

I have seen situations with Google Chrome where it has caused problems with Win 10.  Possibly it might need to be updated, but I will check to see since I don't use Chrome.

The advantage of selecting a headset instead of headphone is the audio quality is lower and requires less processor time.  I would think online gaming would really need the lower quality for performance.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
0 Kudos