Highlighted
vrg1234567890
1 Copper

XPS 13: Cannot turn on... Dead motherboard?

My Dell XPS 13 Ultrabook died yesterday, just four months after purchasing it. I accidentally left the laptop on during the night, but it was basically idle. In the morning everything seemed fine, but when I rebooted the laptop it would not turn on again. Somehow I always feared this would happen, as the booting process striked me as fragile (sometimes I would get stuck on the Dell logo, but after a second try I would get past it). So, after rebooting, the keyboard was lit, but nothing else happened. I didn't even get to the Dell logo... I powered off and on again a few times, hoping that it would just be one of those scary moments (fairly common with this model) and that everything would be back to normal, but the result was the same: lit keyboard, nothing on screen. Also, no beeping sounds and no fan noise. So far, it seems like the motherboard is dead.

A few things I have tried:

1) At first I thought there was something wrong with the residual memory or something similar, so I disconnected the battery and the AC adapter, pressed down the power button for about a minute to drain the residual energy, and then reconnected the AC adapter and turned on the laptop. The result was the same: lit keyboard, and nothing else. I also tried running the battery until depletion, but no luck.

2) To check that the display was OK, I ran the BIST (built-in self test) by connecting to the AC adapter, holding down the D key and turning on the laptop. The screen turned white, red and green for a few seconds, so the test passed.

3) I disconnected and reconnected the two motherboard cables in the back.

4) I let the laptop with the battery and AC adapter disconnected for a full night (running out of alternatives, I guess).

5) I tried the infamous hair dryer technique (YouTube example: /watch?v=Y3h0Tt2cWBs).

6) I pressed the Fn button and turned on the laptop. I also tried pressing F12 repeatedly after powering on, but I knew this was hopeless because, as I said, I don't even see the Dell logo.

And maybe something else, but in any case, it all seems to indicate that the motherboard is dead.

Such a serious failure after only 4 months of use is unacceptable. I am used to laptops which work flawlessly after 4-5 *years* of use, such as all of my Toshiba laptops (with a battery replacement, of course) and my aging Dell Mini 10 (which is why I made this purchase in the first place). I must say that I am very unforgiving when it comes to hardware reliability, so this was most likely my last Dell purchase ever. I just want to make sure I'm not missing anything...

PS: I also had to replace the AC adapter after two months of use, which again shows how cheap and unreliable these products are. As a replacement, of course I got the official (and overpriced) adapter from Dell.

1 Reply
everheul
1 Copper

RE: XPS 13: Cannot turn on... Dead motherboard?

Experienced the same problem with my XPS 13 only 3 months old. Will call Dell support tomorrow.

0 Kudos