Laptops General - Read Only

Last reply by 09-30-2017 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 Ultrabook battery not charging

Hi My year old XPS 13 Ultrabook's battery is not charging when plugged in. I measured the voltage of the power adaptor at the plug (the end that connects to the Ultrabook) and the voltage level seem fine at 19.4V However when I plug and unplug the power when the Ultrabook is off, the LED turns on and off accordingly. My Ultrabook is L321x, running Windows 7, and has BIOS A7 installed. Does anyone have the same issue, and is there anything I can do to check what wrong? Thanks for any help Ka
Replies (53)
2 Bronze
2 Bronze


you'll need to open the back of the laptop with a torx5 screwdriver.

then it's a matter of unplugging the battery.

easy with the right tool.

Now about me...

I obviously have the same problem with a L322X XPS13. It is a REAL problem since now some airport security officers won't let you get to the plane with a computer you can't turn on...

I tried a brand new Dell adapter at a shop, didn't solve the problem.

I had the laptop plug and cable changed, didn't solve the problem.

I changed the battery, didn't solve the problem.

I drained the residual power, updated everything, reinstalled drivers and even windows. Guess what? Yep, didn't change a thing.

I now have an XPS13 that is at 9% from a brand new battery that is going down each time I have a security check at the airport... It's a matter of time until I have to leave it home because it won't charge.

I have now ordered a brand new mainboard / motherboard because it actually is the only thing that is involved in charging the battery I haven't changed...

I'll let you know, what happens with it, guys...

But now, what I can say is Dell laptops sux big time if you are stupid enough not to buy the extended on site support.

2 Bronze
2 Bronze

OK, people, me again.

So I changed EVERYTHING in that *** computer.

I started with the battery, then went to change the motherboard (upgraded to a superior model), this DID NOT change a thing.

Once you spent that much money to change that much, you wonder.

So you go on and change what's left: Adapter. Didn't change a thing. Adapter plug (inside the computer): didn't change a thing.

Went further. Unplugged the SSD and the wireless card. Just to check.


And finally, unscrewed the adaptor plug inside the computer. And "Voila". Don't ask, the BIOS now sees the adapter for what it is, the battery is charging.

Feels like a short circuit.

Whatever it is (if you have an idea... I'll hear it!), if you guys have the same problem... try unscrewing that stupid thing!

2 Bronze
2 Bronze

I remove the little screw.

Guest what IT WORKS!!

You make my month.

I lost my battery icon status but I think that it's because I didn't buy my battery from Dell.

I have no information in the battery information 

Didn't seems to regonize the battery.

But I can disconnect the power and the xps still running on battery.

Thanks again.

2 Bronze
2 Bronze

glad I helped!

it seems that the screw is not the source of the problem but the socket touching the metallic frame.

I will try to put some insulator tape around later to confirm the theory!

I hope more people will come and contribute!

2 Bronze
2 Bronze

Hi ... question:  was your plug loose before or was it nice and tight.

Mine is not charging, but adapter connector is whobbly and loose.   I've ordered a new $7 plug connector wire.   But I was surprised with yours worked right after you unscrewed the plug and and retightened it.

I'm hoping the same.

2 Bronze
2 Bronze

mine seemed tight but I guess it is a matter of a tenth of millimeter!

I changed the plug and wire too, with a cheap eBay too and it works fine!

2 Bronze
2 Bronze

Yes, I tried that ... but the cheap screw broke, making more problems.    I had to order a new $7 plastic AC adapter socket. 

In my XPS13 I7 ... I'm just about finished getting it to CHARGE.

Like others, I replaced the inside A/C socket, replaced a NEW genuine DELL battery Li Ion actually 2 of them, plus a Keyboard for another issue.   I also had purchased the Extended Warranty and my problems all started about 2 months after expiration.   I think DELLs have a internal clock to start a destructive cycle which is paired to the Out of Warranty chip inside.   Because it seems that it immediately calls Dell Service Contract dept to start asking for $239 warranty upgrades.

But that another complaint.  Right now, my Battery Health Check is Normal, the A/C Adapter is pumping out 45W and the Battery Desktop ICON says "Plugged in and Charging" but the battery stays at under 10%.   I have ordered 2 Dell Batteries (genuine $55 ones) and both fail to charge. 

I think the Motherboard changing circuit is BAD but after $140 into this repair, I'm not inclined for pour more money into the Chinese Dell. 

I'm hoping someone this this FORUM has some good tips, or maybe tell me of a Recall which I don't know about.  

I BUY 1-2 laptops a year for my small company ... Dell is not a preferred supplier anymore.  I'm going back to ASUS I think.  This XPS13 i7 was $1700 ... w/o even the Ext Warranty and it lasted 2 years, while the CHIP still have many useful years left in it.  The QUALITY totally failed in this computer, which was purchased to last 5 years.  My company took a 5 yr depreciation on it ... and boom the Dell dies in 2 yrs

2 Bronze
2 Bronze

Nope, I replaced the $7 plug connector and still does not charge.

I also purchase a NEW Genuine Dell replacement battery and it recognized the battery in Battery Health as Normal but would not CHARGE.    I ordered a second battery, thinking I got scammed on the battery purchase and was shipped a Used Battery which was DEAD.  But the second Battery from another genuine Dell supplier also did not CHARGE, although the TaskBar ICON say "connected and charging".

I think the FAULT is inside my DELL's motherboard circuits ... God forgive me on this LEMON.

This is all after replacing the Keyboard for a bad UP and DOWN arrow keys.  What a wreck!

2 Bronze
2 Bronze

Hi, my Dell XPS 13 battery is not charging, tried two different adapters, same message. Tried draining the battery, didn't solve it. Because I'm now at 0% battery, I can't install a BIOS update. Could you please suggest what to try next?

2 Bronze
2 Bronze


Sorry man, if the BIOS and adapter didn't work you have fallen into the DELL design of planned obsolesance and forcing you to purchase a new laptop.   Your motherboard's DC Charge circuit has *** out and is not repairable.  You actually need a new motherboard.  The repair cascade for  where you are is to NEXT:

       a) buy a new battery ($86)

       b) then when that fails, than replace the AC Charging Port Connector on the MB ($25)

       c) then replace the MB ($375)

So ... I suggest that you don't go down the additional $475 path on this piece of *** by DELL.   Check the forum and you will see a very very high incidence of this Product/Design Failure.   Must of the people had this occur within 6 months to 1 yrs of warranty expiration.  This happened to me TWICE, so I am feed up with DELL.  The 2nd time, I had purchased the extended warranty, and the same problem occurred with 6 months of the warranty expiration ... but how did they know?   Hmmm, leads to several product management designed conspiracy theories.   But I'll never buy any DELL.   ASUS is just so much better.

I'm a DELL XPS13 user and a father who purchased another DELL XPS13 for my college daughter, so my situation is true. 

PS:  If you want to try to take more repair steps, I have a NIB XPS13 battery and 2 XPS13 used laptops which you can use as parts.

Signed:   "I Hate Dell"   (

Latest Solutions
Top Contributor