brgnewman
1 Copper

XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

I picked up a Dell Studio XPS 1340 just under 2 weeks ago and as soon as I got it home, I loaded Windows 7 Professional x64 from MSDN on it. I was able to find all the drivers and it seemed to be running fine.

But lately, I have noticed during simple tasks in programs such as Outlook '07, FireFox, Windows Live Messenger, and a few other programs, that the computer will just lockup for about a minute (where I won't be able to do anything) then it will seem to start working again.

During this time, the HD light is lit up (not blinking) and then once the lockup is over the HD light begins blinking again.

I also have noticed there are times when booting the computer hangs for a good 1-2 minutes on the Starting Windows screen (HD light solid).

In Event Viewer there is quite a few of these errors as well:

Event 129, nvstor64
Reset to device, \Device\RaidPort0, was issued


Help?

0 Kudos
1 Solution

Accepted Solutions
UncleScooby
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Well, Dell have finally released a new set of Drivers (A04) and an AHCI fix for the the lock up issue. I have now applied both drivers and also latest BIOS (though this is not needed for this lock up issue).

My nVidia SATA driver is now version 11.1.51.3 and all looks good so far. The Bench Test within the driver gives results the same as the old A00 driver, much better than the A02 driver and the laptop has been behaving and rebooting as it should with none of the lockups experienced with the A02 driver. It is however my first day of use so only time will tell.

I will update after a few days of use to say for sure. Fingers crossed though!

15 Replies
JiM1024
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

I have the same exact issue after upgrading to Win 7 and using the 64 bit drivers. I have been looking for an answer but with no luck.

0 Kudos
labousee
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Hey Guys!

I have the same problem. 

Using the latest firmware from Nvidia 11.1.0.33. 

Did you find any solutions?

0 Kudos
schergr
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Anyone find a solution for this?  Its getting ridiculous.

0 Kudos
UncleScooby
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

So far there does not appear to be a proper solution, however, I have a work around.

The NVIDIA nForce Serial ATA Controller driver supplied with the latest Windows Vista/7 drivers are at fault. To stock the lockups and event log erros simply download the older A00 Chipset driver from Dell. The drivers are only available by choosing Vista as the OS. I extracted the files and then point Device Manager to the drivers to downgrade it to version 10.3.0.42 of the SATA driver.

All lockups have now gone, no more error messages and the Laptop now performs better. Even the bechmark within the driver in Device manager reports a four fold increase in throughput compared to the version 11 driver for Windows 7. I have had no drawbacks from using the older driver.

Hopefully Dell/Nvidia will eventually issue an update to the driver that resolves the issue

cortez.i
1 Nickel

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

@UncleScooby - man! i wish i found this thread 5 days ago!  Event Viewer was logging 180-200 nvstor64, Event ID 129, Reset to device, \Device\RaidPort0, was issued' errors a day for 6 days in a row and the initial Dell Tech support rep did not believe me.  i had corrupted files, indexes, freezing, etc. and it's my (layman's) belief that these delayed read/writes contributed to the demise of my hard drive. Dell Diagnostics was telling me to punt the hard drive, too, WD's hard drive tool was telling me the same thing so i thought it was my hard drive. 

so prior to reading this fix, i purchased a new hard drive (because Dell refused to send me the 500 GB HD that was installed in my laptop by mistake vs 320 GB on the invoice), i installed it and restored from a good backup only to see the same nvstor64 errors within 30 mins of final configuration. there were much less event entries, but the freezing was really bad. next i spent 2 hours on the phone/online with an understanding and willing Tech support person trying to figure out the problem when this thread popped up during my search.  i rolled back to the Vista 64-Bit, NVida SATA A.00 (10.3.0.42) driver and for the last 4 hours not one nvstor64 error.  gosh, i hope this works!  thanks so much for posting your work around!

cortez

studioXPS 1340 w/Win 7 Ultimate

0 Kudos
UncleScooby
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

I am glad some one has found it useful, I found the answer in another forum and posted after trying it out. Since I posted I have had no further lockups and am very happy again, hopefully you will experience the same. I have also contacted Dell support as there are clearly a number of us finding the issue and there is no recognition of the problem. Initially after telling them what I had done the answer came back saying keep checking for later drivers with no axcknowledgemtn anything is actually being worked on. I wrote back again explaining that was not good enough and I want to know that the solution is being worked on and that the Knowledge Base should have an entry for the issue. Here is the response:

"Thank you for replying.

I have reviewed your email and based on that we have already forwarded the issue to our product engineering group for a fix to resolve the issue. As of now, we do not give you any stipulated time period as and when the fix will be released. Please be assured, the issue is under investigation and will come up with the resolution as well.

We have already forwarded your feedback to the concern team.

Should you have any concerns please feel free to write in."

And I have a case number to chase if needed. Fingers crossed they don't take too long and come up with a decent fix.

0 Kudos
cortez.i
1 Nickel

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Normal 0 false false false EN-US X-NONE X-NONE **UPDATE**... ZERO, 0, ZILCH nvstor64 issues for 3 days on my xps 1340. unbelievable!!! i have to wonder what am i giving up by using an older driver vs the newest version? RAID capabilities? NOT!!! Not one time did support suggest i go back to the stock/original driver. Dear Dell, please list this solution as an option for others with the same challenges. NOTE: had to re-post my response, because a (misspelled) word was mistaken for bad language. Brother... fix that bot will ya!

cortez

studioXPS 1340 w/Win 7 Ultimate

Highlighted
kleidi
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Helloooo.....Dell wake up.

How many people must have this problem before you decide to update the drivers?

So does the A00 work?

0 Kudos
cortez.i
1 Nickel

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Installing A00 put an end to my nvstor64 errors; there are no, zero, ziltch nvstor64 errors in my Admin Event Viewer log since i installed A00. if you're as frustrated as i was, it's worth trying... good luck getting Dell to acknowledge this fix.  it simply will not happen.

cortez

studioXPS 1340 w/Win 7 Ultimate

0 Kudos