kleidi
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Hmmm....

I had a look at the A00 file, but the IDE drivers in there seem to be 32bit (nvstor32.sys), and I'm running W7 x64.

What I did was to uninstall the driver from device manager(it asked me if I wanted to uninstall the software and I uninstalled that, too) and let windows install its default drivers Standard AHCI 1.0 Serial ATA Controller. Run a windows assesment test and I was getting the same results. I did not go the way to banchmark the HDD speed and performace but looks like I have lost nothing by unistalling the driver. Now to install the x32 driver on my x64 system i dont know. I am a bit reluctant.

 

DELL can you please stop using nVidia motherboard chipsets. They are good only at graphics and stick with the Intel chipsets (never had a problem with those before).

If anyone finds a better solution to nvstor64, please let us know.

In the mean time, thanks to the contributors and a special thanks to the original solution by UncleScooby

Installing A00 put an end to my nvstor64 errors; there are no, zero, ziltch nvstor64 errors in my Admin Event Viewer log since i installed A00. if you're as frustrated as i was, it's worth trying... good luck getting Dell to acknowledge this fix.  it simply will not happen.

 

0 Kudos
cortez.i
1 Nickel

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

i don't know the difference between the 32-bit and 64-bit versions. like you i'm using Win 7 64-bit.  to date, i have not had any issues with my laptop; it's working and that's all that matters to me. emoticon.Smile.title

cortez

studioXPS 1340 w/Win 7 Ultimate

0 Kudos
hxh103
1 Nickel

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

So is this a problem with the A01 or the A02 file? I have A02 and everything seems to be working fine, although I don't use the laptop for long periods of time, usually shut it down between classes.

0 Kudos
Highlighted
kleidi
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

The problem is with A02 or the 64bit chipset driver for the SATA controller nvstor64.sys

It is strange as to why in some systems the same drivers works and in some doesn't because it is exactly at start up that I had most of the errors. Dell never has replied or commended on the issue.

 

List of drivers can be found in http://drivers.softpedia.com/downloadTag/nVidia+MCP79+Chipset+Driver including A00 and A01 but not A02. I don't know the difference between A00 and A01 but they are released to close to each other.

0 Kudos
UncleScooby
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Well, Dell have finally released a new set of Drivers (A04) and an AHCI fix for the the lock up issue. I have now applied both drivers and also latest BIOS (though this is not needed for this lock up issue).

My nVidia SATA driver is now version 11.1.51.3 and all looks good so far. The Bench Test within the driver gives results the same as the old A00 driver, much better than the A02 driver and the laptop has been behaving and rebooting as it should with none of the lockups experienced with the A02 driver. It is however my first day of use so only time will tell.

I will update after a few days of use to say for sure. Fingers crossed though!

kleidi
1 Copper

Re: XPS 1340 Locking Up + nvstor64 Errors

Jump to solution

Thanks for the update.

It was about time.

 

BTW, I have found that downloading the nVidia graphic drivers from their website increases the performance of the windows index by 1 point.

0 Kudos