Highlighted
MJUlstein
1 Nickel

XPS 15 / 9530 i7 4712 Will not POST (boot) anymore after trying to solve sleep / suspend issue.

Hi, I'm new to this forum. Just got a XPS 15 in the mail and have been following the forums here to set it up.

I got the hybrid model with the 32 GB mSata and 1 TB HDD after reading this article:

Dell XPS 15 (9530) Flawed mSATA Setup

I'm very happy with the computer case, but the HDD was super slow after switching to AHCI in favor of the Rappid start an 16 GB of RAM for the mSATA. (I was going to install a 512 GB SDD instead so this is going off topic)

After setting up the computer the way I wanted I closed the lid and and made some dinner, happy with the computer (apart form the bower connector being very unsafe compared to other modern computers (Mac / Surface etc.)

1. When returning to the computer it wouldn't come to life at all. I was confused, but tried to hold the powerbutton for a little while and then press it again. Sure enough, it had stopped responding in sleep and would need be restarted.

2. The next thing I tried was obviously to click start-power-sleep to see if i was something with the lid. But it remained dead regardless.

I went through 1 & 2 several times eventually concluding with a missing hibernation partition for Intel Rapid Start (It was grayed out & disabled in BIOS) so it became a priority to fix it. So I eventually did but to no avail; computer did not boot a lot faster.

After installing the SSD (Samsung 850 Pro) the computer booted so fast that I actually felt tricked to believe it did sleep and wake up (or at least wake from hibernation.) But then I realized that all the applications I had running hadn't started, so that couldn't be the case.

At this point 2 days of work had passed and I decided to try to set up Ubuntu on the remaining 12 GBs of space on the mSATA.

Not installing anything in particular to my Ubuntu immediately closed the lid and opened it again. watching as the computer just went into sleep and never woke up regardless of how many times i tapped the powerbutton or flipping the lid open. (tried this a few cycles as well.)

My conclusion then was that this had nothing to do with the operating systems, but whit how the BIOS was set to deal with a sleep/suspend request. Sadly I would never be able to figure this out without hacking my BIOS as the power settings tab is hidden in Dell's BIOS (at least in this model.)

When I woke up today I went at it a bit more. (Wasting my entire Sunday.) First I tried to figure out how to reset the CMOS on this laptop, which was not documented anywhere, at  a point where I gave up and started with trying other things. Based on some other thread I tried to disable some USB HID devices, but that didn't help.

I even tried to flash back to the A01 BIOS, but it din't  change anything, so I flashed back to the A06.

The last thing I did on the computer before it got to the state it is in now, ( Not even showing the Dell Logo, just turning the power led on for 1-2 secs then shutting back down. AKA not starting the POST ) was to go into the BIOS And disable any feature that was ticked with "Enabled". That includes disabling visualization, not a good idea, but it shouldn't make the computer not POST. (Idea was to enable one feature at a time if there were a culprit) 

After the last few tests: Disconnecting memory, battery, mSATA & HDD and holding the power button for 30 sec. wouldn't help either. Even tried booting without these devices connected (only AC) and the computer does the same 1-2 sec led light thing as it did whit them plugged in. My conclusion is that the motherboard was faulty and actually switching the settings in the BIOS put it into a different state in witch it wouldn't boot (start POST) at all. I also eventually fond the connector to the CMOS battery (Dell's hidden it well on this and you will have to dissemble a lot to get to the actual battery. luckily the plug is on the topside of the motherboard.)

I let it stay disconnected for a few minutes and held the power button to discharge the motherboard. This had no apparent effect on POST.

I would imagine this could be covered by warranty, but since it is Sunday and i can't call support for another 10 hours, I wanted to start a thread here for others and to document the process. Hopefully Dell tech support in Norway is fantastic. Anyway there might also be a chance that I have overlooked something and can get the system running again without physical assistance, and that would be nice.

I also wan't to add that I have run the Diagnostics and they are similar to my MB Pro which also had a faulty motherboard after two years. The diagnostics would show that nothing was wrong, but Apple concluded with a faulty motherboard after having it looked at. (The behavior before the computer not starting was however a little bit different, but the end result of not going past POST is the same.)

I don't have any experience with Dell support, but I hope I don't have to personally organize shipping within my time of warranty. Also whit the way I'm intending to set up the system (replacing the HDD and reformatting the mSATA) it would be a lot more practical if I would get a shell shipped without  HDD and mSATA installed and thereby be able to move the drives over and send the bad unit back. I don't know if the service with Dell is in that level, but I could only hope. At the very least people should be able to remove the HDD from the machine before sending it, in terms of keeping information secure etc.

0 Kudos
2 Replies
MJUlstein
1 Nickel

RE: XPS 15 / 9530 i7 4712 Will not POST (boot) anymore after trying to solve sleep / suspend issue.

OK, I feel I need to update this thread as the issue has moved. The day after writing the first post I shipped the computer to Dell's third party technicians, here in Norway (Infocare,) thinking that the issue would be resolved.

As far as the service report told me, they changed the Motherboard and tested the system and shipped it back. I asked them to confirm that I could put my system to sleep / standby before shipping it to me, on which they replied the message would be passed to the technician. I doubt that has been the case.

When I got the computer back I immediately tried to start it as is and it booted into Windows as expected. Then i clicked Start-Power-Sleep and the computer shut down. When I re-booted it had hadn't stored anything.

Same as last time I tried to debug a little bit, eventually tried disabling all USB related options in the BIOS and rebooted into Windows.

After setting the system to sleep one last time after that I was left with the same state as the computer  was in prior to shipping it to Infocare.

I called Dell support and said that I had been ignored when it came to input on what needed to be checked while on service, and we came to an agreement that I would be visited by an onsite technician.

I watched over as he switched the Mother Board and the I/O board and after assembling it all together he tried to boot it on battery only. The system didn't show anything on the screen, but POST gave 5 equally spaced beeps. During this he opened the computer and disconnected the battery. Then tried to connect only the AC adapter. And nothing happened. Connecting the battery again while on AC nothing happened either. But whit the AC adapter disconnected he could get a POST signal.

He tried pulling and swapping the RAM a few times, and eventually the system booted.

Now as I'm typing this I'm actually using the computer. The technician did not manage to get it working properly and is now awaiting parts. Current status is as follows.

Will not boot while the AC adapter is connected to the computer. (I can connect it after POST. And it will charge as well as not use the battery while the AC is connected.
The ability to get the computer to sleep is still not working as intended. I have a 16 GB Hibernation partition on the mSATA and Intel Rapid Start Technology is enabled both in BIOS and the windows application.
Suspend in Ubuntu also doesn't put the computer to sleep rather shuts it down.

Currently suspecting the power connection to be the culprit causing the motherboards to fail.

0 Kudos
ngrusz1
1 Copper

RE: XPS 15 / 9530 i7 4712 Will not POST (boot) anymore after trying to solve sleep / suspend issue.

I experienced very similar problems: system would not sleep it would just crash, requiring a hard reset in order to reboot.  After 3 motherboard replacements, I am now experiencing your second issue -- it won't power on, pressing the power button causes the power led to light for a few seconds and then it turns back off, nothing on the screen, no POST, etc.

I wrote a short rant about it on another post (http://en.community.dell.com/support-forums/laptop/f/3518/t/19586456?pi239031352=4).  I'm now waiting to send the laptop to the Dell depot.  Were you ever able to get your problem resolved?

0 Kudos