Highlighted
salanglo
1 Copper

XPS 15 9550 and TB16 Dock

I'm having problems getting a TB16 dock recognized on my XPS15 9550. I updated the BIOS and the drivers indicated in the Dell Thunderbolt Dock TB16 user guide. I connected the AC adapter to the TB16 and then connected the Thunderbolt 3 Type-C cable to the XPS 15. The Thunderbolt icon appears in the system tray but -

1. I get no authentication window to select the user setting.

2. When I right click on the Thunderbolt icon to view attached Thunderbolt devices there are none.

3. Of course no devices attached to the TB16 are visible on the XPS 15.

Attached Devices -

Thunderbolt Details -

I have been previously using a usb-c to Displayport adapter with no issues. Also the power button on the TB16 does power down the XPS 15.

I guess it could be a hardware problem with the TB16 but I'm hoping somebody has seen this and has a solution.

Thanks,

Steve

0 Kudos
5 Replies
Moderator
Moderator

RE: XPS 15 9550 and TB16 Dock

0 Kudos
salanglo
1 Copper

RE: XPS 15 9550 and TB16 Dock

1. My XPS 15 does have a Thunderbolt 3 controller.

2. The BIOS and all drivers were updated as recommend in the 'How to use and Troubleshoot the Dell Thunderbolt Dock (TB16)' prior to attempting to use the dock.

0 Kudos
Goran M
1 Copper

RE: XPS 15 9550 and TB16 Dock

I have also issue with TB16 and Dell Adapter - USB-C to HDMI-VGA-Ethernet-USB  (described here).

Did you make it work?

0 Kudos
Saltgrass
4 Germanium

RE: XPS 15 9550 and TB16 Dock

This is what mine shows on the 9365.  I don't know if it matters as to how many PCIe lanes are used but the 9550 only uses 2, correct?  If it works, it might be limited in some ways.

You might check the settings to see if certain types of devices are allowed or not..

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Goran M
1 Copper

RE: XPS 15 9550 and TB16 Dock

Thanks for your time.

I see same thing but when I unplug TB16 cable and plug in adapter it doesn't works.

This happens when I've installed all drivers for TB16.

Note to future reader/dell XPS buyers having problem with Thunderbolt.

If you wish to have TB16 at home/work and Dell Adapter - USB-C to HDMI VGA Ethernet USB  be careful about it because for me this doesn't work.

0 Kudos