Highlighted
scashman
1 Copper

XPS 15 9550 and WD15 with washed out external display

I have a new XPS 15 9550 that I really like and it has a fantastic display. When I connect it to an external Dell monitor with the WD15 the display image is very washed out. I've updated my BIOS and all drivers to the most current version. It makes the use of the external monitor difficult at best. What's interesting is that when I reboot the laptop connected to the Thunderbolt connector the initial external monitor image is fine and then after a second or two flickers and then changes to a washed out display. I've found that if I keep the laptop open so it's display is up, at times the external monitor's display is OK and not washed out. The WD15 is connected to the Dell wide screen monitor with a VGA connector.

I used this monitor with a Dell Latitude E6420 with no issues at all for years. It still works perfectly with the Latitude. There seems to be an issue with this WD15 or the Thunderbolt connector.

Please investigate this issue and find a solution. It's very frustrating.

0 Kudos
2 Replies
buggaby
1 Nickel

RE: XPS 15 9550 and WD15 with washed out external display

I have seen this on my machine as well (also 9550) plugging it directly into my TV. After a restart, it was fine. There seem to be some issues with the display drivers on this machine, which is too bad since it's otherwise quite good. I hope Dell posts some fixes for this soon.

0 Kudos
Samerai
1 Copper

RE: XPS 15 9550 and WD15 with washed out external display

I have the same problem... and i just received my xps in less than a week... thinking of returning it

0 Kudos