Simon_Tseng
1 Copper

XPS 15 9550 system response very slow or hang when use Broadcom 1830 wlan and DA200 adapter

Hello everyone

My XPS15 9550 HW config is (256GB SSD/8G RAM/ 1830 WLAN card) and i already upgrade all driver & BIOS to latest version from Dell website, till now still occur system response will very slow or hang up on below two condition and already try to re-install win10 O.S many cycles.

those problem is seriously impact my job everyday, till now Dell still can't provide efficacious solution to fix.

have other people also occur those problem? 

1. connect to internal via 1830 wlan card + office SW.

2. connect to internal via 1830 wlan card + connect external monitor via DA200 type-c adapter.

0 Kudos
2 Replies
DELL-Terry B
5 Tungsten

RE: XPS 15 9550 system response very slow or hang when use Broadcom 1830 wlan and DA200 adapter

On the two examples you typed internal, are you talking about trying to connect to your business network when having these problems?  If this is correct do you notice the problem when connecting to your home network or to local hotspots?

If the problems only occur when attempting to connect to your work wireless network have your contacted your IT department and if so what did they suggest?

Assuming that the problem is more widespread and affects more wireless networks this article may be of some help.  

If you don't mind I am going to send you a friend request, so that I can get your information and take a look to see what tech support has already suggested that you try and see if I can't come up with something that may have been missed. 

TB

Specialize in Laptops, Mobile Devices
#IWork4Dell

0 Kudos
Simon_Tseng
1 Copper

RE: XPS 15 9550 system response very slow or hang when use Broadcom 1830 wlan and DA200 adapter

Dear Terry B First of all, thanks for your response on this issue; the issue is not occurred "when you try to connect"; but in the WLAN only when using WLAN or with DA200 conference presentations.

How long will occur lag or hang up? And not a certain period of time.

I've tried several times to re-install win10 O.S, also tried to switch to SATA and RAID mode. Things being equal, BIOS / Driver I have also updated, but still occur.

My XPS15 let me was very embarrassed, because it often crashes during the meeting.

0 Kudos