naterunge1
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

Same thing here. Router doesn't reboot but it renders the network useless in minutes. I've had my network and my neighbors network be affected just by it looking for networks. I have an TP-Link C7 archer. This is NOT an issue with the routers, these cards are more than junk they are dangerous. I also manage our enterprise wifi and I'm afraid of what these cards are doing to it.

0 Kudos
dellmitra
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

Hi! Thanks for the nice detailed posts. I have one question, what type of warranty do you have? I have mail-in warranty and they say that Dell will send an Intel wifi card and I have to replace it by myself or a third-party tec. If I mail the laptop to Dell, they will install another Killer wifi card. Confusing...

0 Kudos
JunW
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

Finally I knew what happened to my wireless router. the first day when I initialize the xps 15. I was trying to connect 5G wireless, it was not able to. I tried with my phone, it was also not able to connect, so I thought my 5G wireless was not functioning(but it never happened before). now I know, 5g wireless is disturbed/killed by the xps 15 killer wifi card.

0 Kudos
anakin1234
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

I am having the EXACT same issue with my 9560. We just got 20 units as company laptops last week Smiley Sad

0 Kudos
fluckaduck
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

I just received my Alienware 17 R4 with the same Killer card. It actually Killed (pun intended) two different routers. A TP-Link AC750 and a TP-Link pocket router. Like the others, i am connected for a few minutes and the pocket router dies completely and needs a restart, the AC750 just crawls to a halt and behaves like a modem from 1992 until we restart it. Going to call support and see what they say. Note that i have 10 other devices that have been using these routers for more than a year without any problems whatsoever.

0 Kudos
AJNMN
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

My XPS 9560 laptop (Which I received yesterday) is having the same problem. Contacted dell support yesterday and technician spent almost 2 hours by taking remote access to my Laptop and tried to resolve the issue but did not succeed? I am having dell premium support but there service *** big time. Worst experience ever. They did not even offer the new Wireless card after wasting my 2 hors of time rather told me that another level 3 technician will take a look on Tuesday. *** Dell. Worst Customer Support. Didn't even care about customer's time and Money. Never recommend to anyone in future 

0 Kudos
Prestonator
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

I'm having this same problem as well.  I've never been so frustrated with a laptop before, not just this issue but the dreaded lagging problem that seems to be very common to the 9560.  I will never buy another Dell laptop.

0 Kudos
Highlighted
dafrizzy
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

I just received my XPS 9560 two days ago and have been plagued with wireless issues. Contacted Dell support twice, updated all drivers and computer firmware but still had problems so they offered to replace the wireless card. I insisted on getting a new laptop instead of just a repair since it was only two days old. It's ridiculous that Dell would continue to ship out laptops with the Killer cards knowing that this is such a widespread and significant problem.

Antonio Khalil
1 Copper

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

I am also facing this problem. I  updated BIOS & wireless card driver but in vain.

Any updated solution ?

0 Kudos
Saltgrass
4 Germanium

RE: XPS 15 9560 Killer Wireless killing my network

Jump to solution

I placed a Killer Wireless 1535 card in my Inspiron 15 7567 Gaming, for testing.  I will be leaving it installed since it seems to be working fine and I like the Performance Suite.

My system did not have a prior install of the Software or Drivers, so this may be part of your problem.  I bought the card online so it did not come from Dell.  Since I am not running your systems, It might be related to just that system.

When I installed, I downloaded the software directly from Killer.  The Dell driver is newer but I think Killer provided a special driver because of this problem.  I am running a Wireless AC Router but I have volunteered to try an N model if desired.

After downloading the required software and drivers,  I would go offline,  Then uninstall everything regarding Killer.

Look at the Programs and Features window to see if any Killer software is installed and uninstall from there.  When you open Device Manager, click on the card and uninstall and check the box to remove all drivers.  If the Killer adapter shows up again in Device Manger, uninstall again until it does not revert to the same Killer adapter designation.

Then reboot to clear every thing out.  Check Device Manger again to make sure the Killer has not come back and then run the Installer.  The one I downloaded for Killer was the

Killer-Ethernet-Wireless_INF.zip.  

I am hoping, removing some prior software or driver which is causing problems with the current install, will help everyone's situation.  

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos