Highlighted
Jack Marcus
1 Nickel

Re: XPS 15 fan, on/off/on/off, gahhh!!!

OK, since it appears to be a common issue, does anybody know what's the best way to approach Dell? I'd really like to see this solved ASAP. When I called customer service, the technician just said he hadn't heard about a widespread problem with the L502x fan.

0 Kudos
OllieKM
6 Indium

Re: XPS 15 fan, on/off/on/off, gahhh!!!

I cannot update the NVIDIA drivers since I could not find a driver package for Win 7 on the NVIDIA site.  I saw a Beta driver but I did not want to install it.

I've had this issue since I got the laptop (received it on Monday).

I suggest raising a case with Dell to investigate.

0 Kudos
nganka
1 Nickel

Re: XPS 15 fan, on/off/on/off, gahhh!!!

Use Dell Vista drivers for Windows 7, it worked for my NVIDIA, and I had the same fan issues on a Latitude D630 after a rebuild which I solved with updating the BIOS.

If the lastest version Bios is causing the problem maybe try an earlier version.

 

Latitude D630 T7300 2 Ghz / Windows 7 Pro / 500GB Momentus XT Hybrid HDD  Seagate 7200/4GB of solid state SLC NAND flash storage  / 4GB Geil 800 Mhz RAM / Custom paint.

0 Kudos
frankfletcher
6 Indium

Re: XPS 15 fan, on/off/on/off, gahhh!!!

Thanks, but...

 

I have the latest Dell drivers for NVIDIA and the latest Dell Bios (A04).  My fan problem still exists.

In fact, I didn't have a problem until I upgraded my bios from A01 to A04.

 

 

0 Kudos
Jack Marcus
1 Nickel

Re: XPS 15 fan, on/off/on/off, gahhh!!!

Thanks, but...

 

I have the latest Dell drivers for NVIDIA and the latest Dell Bios (A04).  My fan problem still exists.

In fact, I didn't have a problem until I upgraded my bios from A01 to A04.

 

Can we go back to A01? My 502x laptop arrived last week so I've always had BIOS A04.

0 Kudos
frankfletcher
6 Indium

Re: XPS 15 fan, on/off/on/off, gahhh!!!

 

There is a copy of A01 available here:  http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R297342&SystemID=XPS_L502X&servicetag=&os=W764&osl=en&deviceid=27126&devlib=0&typecnt=0&vercnt=2&catid=-1&impid=-1&formatcnt=0&libid=1&typeid=-1&dateid=30&formatid=-1&source=-1&fileid=446147

 

I haven't tried installing it yet so I don't know if it works.  🙂

0 Kudos
nganka
1 Nickel

Re: XPS 15 fan, on/off/on/off, gahhh!!!


frankfletcher wrote the following post at Sat, Apr 16 2011 7:49 AM:

 

There is a copy of A01 available here: http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R297342&SystemID=XPS_L502X&servicetag=&os=W764&osl=en&deviceid=27126&devlib=0&typecnt=0&vercnt=2&catid=-1&impid=-1&formatcnt=0&libid=1&typeid=-1&dateid=30&formatid=-1&source=-1&fileid=446147

 

I haven't tried installing it yet so I don't know if it works. 🙂

 

 

Hey Frank, are you going to try A01. Interested to know if it solves the problem. And if it does, what other BIOS updates do you miss out on by going back.

Latitude D630 T7300 2 Ghz / Windows 7 Pro / 500GB Momentus XT Hybrid HDD  Seagate 7200/4GB of solid state SLC NAND flash storage  / 4GB Geil 800 Mhz RAM / Custom paint.

0 Kudos
OllieKM
6 Indium

Re: XPS 15 fan, on/off/on/off, gahhh!!!

The real question is, can you downgrade the BIOS once you've gone to A04.

The major ehnancement that I can see with the A04 BIOS is that the SMBIOS was upgraded.  This may be relevant to the fan constantly spinning up.

0 Kudos
Jack Marcus
1 Nickel

Re: XPS 15 fan, on/off/on/off, gahhh!!!

If anyone has tried to downgrade the BIOS from A04 to A01, please report if there's any noticeable improvement with the fan issue.

0 Kudos
Shogoot
6 Indium

Re: XPS 15 fan, on/off/on/off, gahhh!!!

bump

0 Kudos