bdvtje
1 Copper

XPS 15 plugged in, not charging

My 5 months old Dell XPS 15 was running low on battery and when I plugged in my charger I saw the message: "plugged in and not charging". I contacted Dell Support but I'm wondering if there is something I can do in the meantime?
I already tried to update my bios in the hope that would help but my battery is at 7% at this moment and Dell doesn't allow a bios update when battery percentage is below 10%.

Tags (1)
0 Kudos
1 Reply
Moderator
Moderator

RE: XPS 15 plugged in, not charging

Hi BDVTJE,

What is the exact system model? 

Are you using an original Dell OEM Adapter? When you plug in the adapter to the system, does the adapter stay firm or does it fall off easily? Is the adapter frayed? Is there any damage on the system? Could you test with another power adapter if possible?

Restart the system and press f2 key to enter BIOS - check the adapter status in BIOS with and without the adapter plugged in. Also, wiggle the adapter cable at the end and see if the status changes in BIOS at any point. Check the battery health in BIOS (if applicable).

Ensure you back up all imp data on the system and then force the BIOS flash if required - http://dell.to/2hnhjs4

Restart the system and press f12 key on startup - choose diagnostics. Let it run the diags and if you encounter any errors - make a note of the complete error and report the same to us. These are onboard diagnostics and they might possible pick some error if the hardware is not functional.

Test with another adapter and battery first, if the adapter fits in loose, then replace the dc port, if nothing works, then the motherboard might be at fault.

Also, please click my DELL-username and write me a private conversation with the service tag and your contact details(Name and Email) for case records.

Let us know if you have any other queries.

Thanks and Regards,
DELL-Rishi
Social Media and Communities Professional
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos