Highlighted
RAlbasini
1 Copper

XPS 9550 - Poor performances with closed lid

Hi,
I own a DELL XPS 15 9550 with a 4k screen, and in general, have no complaints about it. 
The major issue I encounter is when plugged in an external monitor (TV) by HDMI. With the lid open, no issue, I can watch HD movies with great performances. The problem occurs when I close the lid or choose to display the screen on the external monitor only. 
Videos lag heavily, and the video stream renders poorly. After some digging, I found out that it was probably some sort of "power saving" mode automatically enabled with closed lid. I found this topic documenting the same issue. 

www.tomsguide.com/.../laptop-graphic-performance-decreased-laptop-closed.html

Problem is, I can't find any useful setting on the BIOS that could result in those poor performances. 

Any help ?

Thanks !

0 Kudos
5 Replies
dell-robert p
6 Gallium

RE: XPS 9550 - Poor performances with closed lid

Hi RAlbasini,

Thanks for posting.

I see you've tried various things to resolve your issue.  Have you seen this one?

http://dell.to/2y1Ouwf


0 Kudos
RAlbasini
1 Copper

RE: XPS 9550 - Poor performances with closed lid

Hi,

Thank you for your answer, but I think you misunderstood the situation (maybe I wasn't clear enough).

I don't have any issue regarding sleep/hibernate waking up my computer by itself. Closing the lid doesn't put my laptop into sleep mode, and that's what I want it to do.

My goal is to be able to connect the laptop, with the lid closed, on an external screen with an HDMI cable, and still have a powerful machine to render HD video on this external screen.

Current situation is : with lid closed and with an external display, the laptop seems underpowered, as if the generic Intel graphic card was used instead of the NVidia, resulting in poor performances.

I'll repost the link of the same situation I encounter :

www.tomsguide.com/.../laptop-graphic-performance-decreased-laptop-closed.html

Thank you for your help

0 Kudos
dell-robert p
6 Gallium

RE: XPS 9550 - Poor performances with closed lid

What docking system are you using? 

0 Kudos
RAlbasini
1 Copper

RE: XPS 9550 - Poor performances with closed lid

No docking system, just a simple HDMI cable

0 Kudos
dell-robert p
6 Gallium

RE: XPS 9550 - Poor performances with closed lid

Since you've tried all the suggestions I have, perhaps contacting Dell Tech Support for additional troubleshooting and possible resolution?  

You can contact Tech Support at 1-800-624-9896  or 1-800-288-4410, or you can initiate a chat session http://dell.to/2v4snVm

0 Kudos