markopelli
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

Working?  

"... But it does lose the wireless mouse..."

I wouldn't call that working ...

And no, mine still doesn't either.

markopelli
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

The latest version of the XPS 15 9550 system BIOS is:

Version: 01.01.19

Release Date: 05 Feb 2016

Are you sure you are talking about the same Dell laptop?

I have updated/installed/reinstalled/rebooted everything MANY times, following strict ordered instructions from the Dell website (there are actually three slightly different versions if you keep digging, minor ordering differences), as well as a couple from the web (right here included).

The most stable I have been able to achieve still intermittently/ regularly loses the external monitor (Dell U2410) connected via DisplayPort.  HDMI to my other U2410 doesn't currently this problem.  Seems like the only "reliable" way to get it (DisplayPort) back is to disconnect the dock, power off the dock, reboot the laptop, powerup the dock, and connect the dock.  I've swapped monitors/cables/ports - problem follows any DisplayPort connection.

Prior to this I was using a D3100 dock and everything worked perfectly, But it didn't provide power, have Thunderbolt, or USB-C, so I "upgraded" to the TB15 ... which has been nothing but a nightmare.

Grrr

0 Kudos
erwinrichard
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

unfortunately some of the newest drivers from dell made it worse in my case. halfway stable here - except for the really annoying fan noise - after i downgraded the Realtek Ethernet driver to the last version on their website (not the dell download).

Went from BSOD every hour to now about once per week  but still not really solid. unplugging devices while running is a bit of a *** still.

0 Kudos
erwinrichard
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

Dell edited out the Word *g*a*m*b*l*e* in my last post. Probably for a good reason :-)

ncfitzge
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

Ya, new updates made things worse. My screen randomly shuts down and have to restart to get to work. Might try and return and go mac.

0 Kudos
rkolpien
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

I have tried all of the above, and I seem to now have a stable connection to my two 4k monitors.  However the wireless mouse and keyboard are intermittent at best. 

0 Kudos
frost2112
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

Everything is working for me except closing the lid! After a minute or two, the screen goes to sleep! I should not have to EVER open my laptop if I have this dock. Reality is that it hasn't been closed since I bought it...

Very disappointed Dell hasn't fixed this. I even had Support take remote control of my computer. Over an hour later, still no fix...

FIX THIS DELL BEFORE I RETURN EVERYTHING AND BUY A MAC 

0 Kudos
Jandaduns
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

I had same issues (sporadic Internet - or not - and USB mouse//keyboard working for a few seconds before dropping). I had all the latest drivers installed - newer than listed above. Reinstalling drivers a few times did not give relief. Then I stumbled on above instructions...

I meticulously followed the instructions  above (with the latest drivers available) with a FULL restart (maybe that's the trick?!) after each step - I did notice that in most cases the Dell logo comes up twice instead of once - so definitely something is happening on restart.

Has been working without any drops from USB or Internet...

Note that the instructions are similar to the suggested Dell installation order, with the exception of first unintelligible the Thunderbolt drivers (which I did uninstall, just to be sure): http://en.community.dell.com/support-forums/laptop/f/3518/t/19677047

Update April 28: never mind. It's worse now than before. Worked for 2 days, now have also dropping video signal for a few seconds and occasionally permanent as well as Ethernet and USB connections dropping. Absolutely unusable. I will be returning this dock immediately. :-(

Update April 29: I did get an RMA - so far so good. I remembered however that I saw in the Windows Event log that the "Realtek USB GbE Family Controller" had a Fatal Error: The IM miniport has failed to initialize. The most recent Dell Driver has version 2.43.2015 (note the year...). I went to the Realtek website and downloaded the RTL8153 RTL8153 driver for Windows 10 (that's the Realtek driver for Ethernet over USB 3.0). Link here: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=56&Level=5&Conn=4&DownT...

When installing this driver, Windows 10 sees this as a 'repair' of the existing driver and reports version 10.7.218.2016 (again: note the year). It shows still under "Realtek USB GbE Family Controller" in my Device Manager. It has been working stable now in the past 3 hours - will see if it holds up during the weekend - or not. I'll keep you posted.

Update April 30: nah, still same issues. Will be returning the dock today. Never a Dell again for me.

Tags (1)
0 Kudos
reenagr
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

They don't, still having issues after updated.

0 Kudos
toddwh505
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

I did all of this and it is a bit better, but I still have a lot of issues.

I have two "identical" docs, one at home and one at work. The doc at home seems to have more issues (external monitor intermittently goes blank, USB peripherals lose connectivity).

But both docs still seem to mess with the laptop's ability to sleep and wake up gracefully. Every time I try to sleep the laptop then wake it up on a different doc (home vs. work), the screens (including the one on the laptop) are black and I end up having to do a hard reboot.

I'm Just about at the end of my patience and ready to return everything and end this $3000 failed experiment. I didn't realize how much this combination of hardware was still in a "beta test" state.

0 Kudos