jjsalaza
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

I absolutely agree with you, and I am also very disappointed with my DELL XPS 15 9550 and DELL dock thunderbolt TB15. From time to time, in a non regular base, but frequently, only my external 4K monitor keep active, while I lost the connection to internet cable, external keyboard and external mouse. The only way to have them active back is to reboot the notebook. According to DELL Update, I do have the last version of all drivers. In addition, the fan of the notebook is working hardly when the TB15 is connected: quite disappointed! I did not expect being used by DELL in this "beta test" state of the TB15.

0 Kudos
manor_a
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

I have an XPS15 + TB15 and I have been unable to connect even a simple wireless mouse through one of the USB ports on the dock -- with two separate units (I was shipped a "replacement unit"). This is amazing as it essentially proves that DELL cannot deliver on the most basic dock functionality. I even have an L2 level tech on record as saying that: "some of the functionality of the device are somewhat non-functional as of the moment." I am really impressed with DELL's ability to get the idea that the TB15 was ready for prime time through "demos" at all the trade shows and industry rags. Well done to the PR department. I also have $3K worth of laptop which is now significantly hobbled by the lack of a proper dock (and of course the whole silliness with the "nostril-cam" -- we get it, you have no bezel, but guess what, putting the builtin webcam at the bottom of the screen means you have no bezel and no functional webcam either). I should've waited for the Skylake Macbook Air...

0 Kudos
JohnSCarroll
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

No.  I just spent several hours with Dell support.  All new drivers, new BIOS.  Same problems persist.

0 Kudos
PapaGMan
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

You have to be the unluckiest person to returned 4 Dell XPS 9550 for motherboard problems. It's almost unheard of. I can see one in 1000 having motherboard issues but you have 4 in a row! wow! Last Christmas I purchased 5 (non-touch i5pr) of these machines for my business, and 2 (touch 4K i7pr) additional for my kids and 2 (non-touch i7) more afterwards 2 months later (One for myself and my manager). Of the last two, one had an issue with the SSD but the tech came and reseated it and voila no problems.  Out of all these excellent laptop I had just that one issue. My employees are really putting these machine to the test and they're working extremely hard. We constantly use the Thunderbolt (Main reason why I choose these Dell XPS) and so far we have not had any problems with them since and the recent updates.

So before you start wondering why your Thunderbolt Dock is not working I think you should find out what's causing your motherboards to fry. I would get someone that knows what's going on and check your setup. Maybe your problem is when you update your Bios. Perhaps you didn't fallow the right procedure. I don't know but something you're doing is not right. So before you "fry" another mainboard get some help.

Gerrit1980
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

As so many, I still have problems with my setup (tb15 / xps 15 - 9550). Sometimes the Ethernet adapter just disappears (The Realtek USB GbE Family Controller) with no message in the eventlog, monitor stops working (VGA - no signal and no longer visible in windows 10, HDMI still works though). The USB-C adapter to VGA/Ethernet/HDMI/USB (thunderbolt connector) seems to have the same problems. Tried many topics on the internet; drivers, sequence, reinstallation, disable c-state, disable thunderbolt security etc. No real difference.

So far the best option for me to work with 2 screens is connect one via HDMI to the TB15, and one directly to the laptop HDMI. Keyboard and mouse are connected to the laptop directly, since the USB on the TB15 is also unreliable. Just leaves the ethernet; I am waiting for my USB-3 adatper to VGA/EthernetHDMI/USB to check if I can get that stable. I will let you know.

This all does bypass the purpose of a 'docking station' somewhat, but it is either that or have 3k of hardware sitting in the closet. I am afraid to call Dell support since they are clearly inadequat to correctly handle a DOA, so I will wait for drivers.


A final tip; I could not return the items because I bought them via my company (I am self-employed). In the Netherlands, consumers are protected by law against mis-buys and you can return stuff with ease. But as a business I was unable to return 3k of hardware which clearly does not 100% (should have) passed QA. So a tip for you self-employed people out there: buy it personally if you are in the Netherlands.

Tags (2)
0 Kudos
gapus
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

I have a precision 5510 and using TB15 with Dell ultrasharp 4HD monitor.  USB failure. USB device overheat.  Display intermittently dithered with strips of odd color which change each time I reset the monitor.  I hope it is just the TB15 and I can find a replacement.  I have a support ticket but reading these comments makes me think I will do a lot of troubleshooting for naught.  All drivers updated, BTW and still having these major problems.  A lot of money and at least 10 hours on support lines so far.  

0 Kudos
Gerrit1980
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

After a couple of days I can confirm that the USB-3 to HDMI/VGA/Ethernet/USB has a stable ethernet connection. Just  to clarify: the USB-C connector is the DA200 model which is unstable. The DA100 model is USB 3.0, works on the xps15 (9550) and is stable.

Note that I tested this for normal work/home usage, not gaming or other real-time communication. So I have not tested latency, or 'temporary disconnects' as in a hicks that reconnected withing half a second. I have not noticed these cases and have no reason to believe this happens, but just in case someone comments my disclaimer.  

0 Kudos
Gerrit1980
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

After ethernet problems, I noticed that the Thunderbolt software claimed both my dockingstation were disconnected (system tray Thunderbolt, manage approved thunderbolt devices). I removed them and restarted XPS and reconnected the tb15. It has been up now for the past couple of hours.

I tried a phonecall to the dutch Pro-support of Dell. They claim to not know what Dell is up to and cannot say if Dell is working on this issue and when to expect new drivers or a recall. Since the latest drivers for the XPS are more than 30 days ago, I think the problem is not easy or (since that they do not even bother informing the Dutch branch of their actions) they don't care... a shame.

0 Kudos
erwinrichard
1 Nickel

RE: XPS 9550 not working with TB15 Dock

Jump to solution

according to this post, the TB15 is being recalled at least from the shops. I got a replacement unit 10 days ago but it seems to expose the same thermal problems. Had not time to fully test yet.

http://www.itcentralpoint.com/dell-recalls-tb15-docking-station

0 Kudos
wanguru73
1 Copper

RE: XPS 9550 not working with TB15 Dock

Jump to solution

I'm using a Logitech Unifying Receiver, plugged into the front right USB 3.0 port on the TB15. I have a Performance MX mouse and K800 keyboard paired with the receiver. The mouse and keyboard work intermittently upon reboot, then quit working about 3 minutes after login. I can move the receiver to the USB 3.0 port on the XPS 15 9550 and everything works fine. Move it back to the TB15, no dice.

The problem is, I only need this dock at work, and thus the receiver, keyboard, and mouse, to stay at work. I would prefer not to keep the receiver plugged into the laptop all the time.

0 Kudos