Highlighted
th2018
1 Copper

XPS 9560 thinks TB16 is always connected, but dock doesnt work

I have a new XPS 9560 and a TB16 dock. Up until a recent auto-update, both worked fine.

After the update, the ethernet and USB on the TB16 would not be detected. I reinstalled all drivers, but no luck. The new Thunderbolt firmware update listed on the support page also wont install as it says 'needs latest thunderbolt controller' - I have the latest controller.

Looking at Dell Command Update, this is what is says for Thunderbolt, the firmware entry doesn't look right





And this is what the thunderbolt software says:



So ive done a fresh Win10 install, but before i even connect the TB16, Windows starts installing the thunderbolt drivers and constantly says "Base System Device" connected. This even happens if i disable Thunderbolt devices in the BIOS.
So it seems to me like the laptop thinks the dock is permanently connected, even when it's not.

Anyone have any ideas?



0 Kudos
7 Replies
Saltgrass
4 Ruthenium

RE: XPS 9560 thinks TB16 is always connected, but dock doesnt work

The software you show is newer than mine but I show a controller driver version and you do not.  The attachment was taken when the 9365 was not connected to the dock.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Saltgrass
4 Ruthenium

RE: XPS 9560 thinks TB16 is always connected, but dock doesnt work

You may already know the controller is on your computer, not the dock.  That is why you install all firmware and drivers before you connect the dock.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
jphughan
5 Rhenium

RE: XPS 9560 thinks TB16 is always connected, but dock doesnt work

Do you remember what the auto-update was?  If it was just a BIOS or just a Thunderbolt firmware update, then that could be the issue.  The typical sequence of updates is that the system BIOS needs to be updated first, then the Thunderbolt software, and finally the Thunderbolt firmware, because that last one won't install properly if the BIOS and software aren't up to date first.  You may want to go to support.dell.com and manually download and run those updates in this case.  It might bring things back to normal.

0 Kudos
th2018
1 Copper

RE: XPS 9560 thinks TB16 is always connected, but dock doesnt work

@saltgrass

Yeah, all updates were done with the dock disconnected

@iphugan

I think it might have been the BIOS upgrade to 1.3.4, but cant say for sure. Am running 1.5.0 now

It's definitely something non-OS related, as ive reinstalled fresh a few times now.

May have to go down the MB replacement route, but would rather avoid if possible/

This is the log generated when i try the firmware update:

*** Dell Thunderbolt firmware update started on 9/16/2017 at 20:46:21***

Command: C:\Users\XX\Downloads\Intel_TBT3_FW_UPDATE_NVM21_318RY_A01_4.21.01.002.exe

Starting FW Update....

Power is on already

Thunderbolt Firmware Update

C:\Users\XX\AppData\Local\Temp\DELCB22.tmp\Intel\FwUpdateCmd.exe /s up1 C:\Users\XX\AppData\Local\Temp\DELCB22.tmp\Intel\0x07BE_secure.bin  /s up1 C:\Users\XX\AppData\Local\Temp\DELCB22.tmp\Intel\0x07BE_secure.bin FAILED:

The Intel Thunderbolt(TM) Controller Driver needs to be installed before the Thunderbolt(TM) firmware can be updated.

Please visit Dell web site to download the latest version and Install the driver. Then re-run this utility. : error 0xc

System TBT NVM Current Version:BCD:0000020b: New Version:BCD:0000020b

Error: Unhandled Error

An unexpected error was encountered.  Please record the error return code and report back to technical support.

Exit Code = 10 (Unspecified Error)

***Thunderbolt Firmware flash finished at 9/16/2017 at 20:53:09***

Given the section in bold, am wondering whether i have the latest fiirmware installed anyway?

0 Kudos
Saltgrass
4 Ruthenium

RE: XPS 9560 thinks TB16 is always connected, but dock doesnt work

I just updated my drivers.  If you notice the override box, the software checked it.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
th2018
1 Copper

RE: XPS 9560 thinks TB16 is always connected, but dock doesnt work

thanks, but that doesnt help me much!

0 Kudos
Saltgrass
4 Ruthenium

RE: XPS 9560 thinks TB16 is always connected, but dock doesnt work

Your attachment shows you have not controller driver installed.  Has that changed and you now show a controller driver version.

The normal install sequence would be do the firmware, which probably only needs updates, and then the controller driver.  If you noticed this note:

"The Intel Thunderbolt(TM) Controller Driver needs to be installed before the Thunderbolt(TM) firmware can be updated."

I do not use Dell Command so no experience with it.

On the TB16 site there are two downloads.  One for the firmware and one for the controller driver.  Did the Controller driver install work?  Do you have the box checked to allow out of sequence devices?

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos