Highlighted
luckykhalid
1 Copper

XPS M1530 not starting, no startup sound

Hi,

I have Dell XPS M1530 Laptop that I bought from states in Jan 2008. Now, when I press start button nothing happens. It does not start and I dont hear any startup sounds like fan/hard etc. Only the start button light turns on for 3 seconds but nothing happens from onwards. Last night when I switched it off, it was very hot and the time was lacking 3 hours behind the original time. So I turned it off, which went fine. But today morning it just does not respond as if being dead.

I remember that the similar problem occured an year ago but then I took off its battery, let it be out for an hour then again put it back and then switched it on and it started working fine. But now this trick is not working Smiley Sad.

Please let me know what's wrong with it and how can I bring it back. I just don't remember if I bought extra warranty or not.

Many Thanks,

0 Kudos
1 Reply
8 Krypton

Re: XPS M1530 not starting, no startup sound

First verify that the LED on the adapter is ON before you plug in the notebook end.  If it is not, replace the adapter.

If the LED comes on but goes off when you connect the notebook end, the mainboard in the notebook is faulty.

If the LED stays on, try without the battery.  If the system will power up, then the battery is faulty;  replace it.

If you still get nothing, try reseating both memory modules - remove and reinstall them. 

If you then still get nothing, the mainboard in the notebook is faulty.

 

0 Kudos