1 Copper

XPS13 9350 USB Win 10 Recovery/Reset fails

Hi everyone,

I need some help recovering Windows 10 on my XPS13 9350. Due to a charging issue the motherboard and ssd were replaced by DELL yesterday. However left me without a working system (I needed to restore Windows myself). What I've done:

  • Download a windows recovery image selected via my service tag.
  • Installed the ISO on a bootable USB drive
  • Booted from it, and started recovery, full clean.
  • The laptop starts working and counting percentage. Right after 99% it says: there was a problem resetting your PC.
  • The end. No further info.

I tried recovery, reset, I tried different BIOS settings (but I don't know what they should be!!. The laptop asked a few times to enable TMP, which I did.

I tried to create a Dell Recovery & Restore USB drive, but the tools to create one only run on Windows (whereas the only working OS in my home is OSX).

Now I'm stuck, I don't know what to do to get Windows running. Who has any tips for me?

0 Kudos
1 Reply
1 Copper

RE: XPS13 9350 USB Win 10 Recovery/Reset fails

Perhaps you should check out all the steps for rebuilding your disk environment in the document "Dell XPS 13-9350 Re-image Guide".  Nor easy, but at least it's comprehensive. Guide_en-us.pdf

0 Kudos