Laptops General - Read Only

2 Bronze

dell xt2 lan "code 10" error

hi;

i got a dell latitude xt2 oem that was never activated (service number is 12345) and i cant use the lan.

the driver show a "code 10" error.

how can i enable the lan.

Replies (7)
DellEMC

Is the WIFI LED lit up or dark?  On the XT2 only the WIFI radio or the mobile broadband radio may be active at the same time.  If you have not tried to do so yet, I suggest hitting FN +F9 to swap between the two different radios and see if you are able to connect.

TB

Specialize in Laptops, Mobile Devices
#IWork4Dell

2 Bronze

the wlan works fine,its the network card that don work

9 Rhodium

Code 10 is an error code generated by Device Manager in Windows.

If the device has a FailReasonString value in its hardware key, that string is displayed as the error message.

The driver or enumerator puts this registry string value there.

If there is no FailReasonString in the hardware key, you receive the following error message:

This device cannot start. (Code 10)

Recommended resolutions

Here are some things that you can try to resolve this problem.

Update the driver

In the device Properties dialog box, click the Driver tab, and then click Update Driver to start the Hardware Update Wizard. Follow the instructions to update the driver.

You may be prompted to provide the path of the driver. Windows may have the driver built-in, or may still have the driver files installed from the last time that you set up the device. If you are asked for the driver and you do not have it, you can try to download the latest driver from the hardware vendor’s Web site.

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support


Get Support on Twitter @DellCaresPro


Diagnostics & Tools

DellEMC

Thanks Speedstep

I am sorry that misunderstood your post elivkll. Please let us know if you continue to have problems.

TB

Specialize in Laptops, Mobile Devices
#IWork4Dell

2 Bronze

i tried to update the driver,it didnt work.i think this is a hardware issue linked to intel amt (intel active managment technology) the chipset wont activate the lan until you activate the "amt".does sombody knows how ?

DellEMC

Intel AMT should be disabled by default, unless it has been enabled, it should have nothing to do with the ethernet adapter and network performance.  Here is some information regarding Intel AMT regarding networking.

Intel® AMT can be set up for either Enterprise or Small and Medium Business operational modes (also called provisioning models). Both operational modes support dynamic and static IP networking.

If you use dynamic IP networking (DHCP), the Intel AMT host name and the operating system host name must match. You must also configure both the operating system and Intel AMT to use DHCP as well.

If you use static IP networking, the Intel AMT IP address must be different from the operating system's IP address. Additionally, the Intel AMT hostname must be different from the operating system's hostname.

So if AMT has been enabled you may want to check to see if it has been configured for either DHCP or static IP.  You must have the notebook connected to a network where it can find your networks SCS (setup and configuration server).  So if you have hooked up your notebook to a domain network and your IT dept has configured your notebook to enable AMT, then it should be disabled and it is not the problem.  Otherwise I can only suggest that you contact your IT administrator and have him configure your notebook correctly.

Otherwise we are looking at a driver, windows or ethernet adapter problem. I suggest completely removing the ethernet adapter driver from add / remove programs and from the device manager and completely reinstall the driver.  If that fails you have two options, reinstall Windows or have the system board replaced.

TB

Specialize in Laptops, Mobile Devices
#IWork4Dell

2 Bronze

I have the same problem with my XT2. But I noticed the driver for the LAN is 82566DC . Its spose to be 82567LM. But mine wont even install the OE Drivers even from the OE disk CD/DVD. I have reinstalled OS and the drivers many times before but now Nothing seems to work proper.Please email me.

Top Contributor
Latest Solutions