dfwh
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

Hi Amagi,

Just try a self booting CD/DVD as described in my article (dfwh),  as you may have to update the BIOS.

A simpler way as described, would be using a spare laptop hard drive with a simple XP installation to

update the BIOS. If you can't get a screen display with any method described either the main board or

the screen is faulty.


Cheers


dfwh

0 Kudos
JacobOcana
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

I received the attached error. Know of a solution?

0 Kudos
Bilawal Buddy
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

Same problem with me and I can't go in my bios when I press F12 or F2 it's go black screen if you find a any solution plz tell me
0 Kudos
clowmilk
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

thanks for this suggestion

apparently it's one of my USB ports as well, shorting out something

In my case it's the front one on the right side

plug something into it and it boots fine

take it out and the mystery black screen reappears 

0 Kudos
Mario71
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

Hello

today I experienced the same problem: Black screen at boot up on Dell Latitude 6430u. Windows booting it was ok (I  heard the windows sound at login). Only two times the dislay got back lighting, properly.

I tried many times to witch it on and off, unsuccessfully.

Then, I unmounted the battery and the back cover (refer to Dell Manual documentation statementes, to do it) and I found the Display LVDS cable partially umplugged from its soket. I plugged in the LVDS cable within its soked and the problem seems disappeared.

thi is my experience.

Bye bye

Mario 

tomosendre
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

Man,

You Rock.

I was aware of a faulty USB port on my e6420 but didn't think of it as the cause of this issue.

Thanks to you it is usable now.

Kind Regards,

Endre

0 Kudos
LePastore27
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

Hello,  i have a Dell Latitude E6420.  When i switch on it boots but i don't see the logo on the screen even after booting. The screen is on but nothing displays. I tried one solution you gave on a previous post( unplug charger and ac supply then press the power button for 20sec. Switch on after plugging the ac supply and hold press the fn ket for diagnostic test to appear)  it produced a beep sound signaling an ongoing diagnostic but nothing displays on the screen. Please whet is the cause and what should i do ? My graphic card software crashed a week ago. Please help me ??

0 Kudos
tomosendre
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

Based on the sympoms my fist guess is a faulty GPU. Is your E6420 a discrete grphics (nVidia) model or oa built-in (Intel) graphics model? If it is a bulit in graphics, than the gpu is in your CPU. You can try another processor with your machine. You can pick up a used i5 for a few dollars.

The discrete graphics is bulit on the motherboard, so I have no ide how to diagnose that. Someone could help. 

0 Kudos
oliviun
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

Hi to all and sorry to hear that Dell kinda became a lame brand...

My history:

Always wanted a Dell, i have dream about it - a powerful beautiful long lasting piece of tech.

Started to search online a laptop e6420, e6430 something in this area.

One day i find it: e6420 i5 4gb back-light keyboard webcam, all perfect BUT without HDD - 75€ price, i have jumped on the seller, send it an sms and one hour later my dream was in my back sit on my car on the road to home.

The moment i have buy it i have powered on the laptop, entered the BIOS - all was there: the CPU, the RAM all settings available.

Back home i have put it in my desk and let it there few days as i was busy with some home improvements.

2 days ago i have plugged in a 500Gb fully working HDD (with WIN7 installed) and pushed the POWER button.............. after Dell logo screen (i start to hate it actually) the screen goes BLANK, the only thing i see is a cmd type cursor that flicker 2-3 times than NOTHING !!!

Oh boy i said... something smell like cat ***... Going online and first gggl results was this bleeding Dell forum Smiley Sad( SO my dream was washed away totally, and i have advised ALL my customers or friends to buy a Dell if they want a solid machine Smiley Sad stoopid move...

Of course i have opened the back cover, powered on and to figure out that the fan is not spinning at all and the pipes became very hot in a matter of 10-20 sec.

Can i have the HUGE luck to replace the fan and the laptop became functional ???

I will totally take it apart and see if the LVDS cable is ok and i don't know.

If i will not be able to find a fast and cheap fix i will spend my time and energy to make people know about the going down dell brand.

I mean boys how the FK could you make a BIOS update (to fix heating problems) and damage the motherboards ???

Yeah you could tell me that's the risk if i have buy it on the street corner... ok but when i see that the exact the same model was fried after 1 year, i congrats myself, at least i have not payed a ton of cash for a under mediocre product...

I'm not saying that all Dell series ***, but for me FIRST contact matters, and for the moment the first contact became the last one.

So sorry to OP if i have posted on the wrong section, anyway i see that the dell geeks don't even bother to answer anymore so another "pink" point for your services...

Hope you all to find the cheap solution and fix your to pricey machines...

Have a not blank dell style day

0 Kudos
oliviun
1 Copper

RE: my dell latitude e6420 screen goes blank when it has to boot

So "proudly" Dell E6420 owner...

Symptoms:

- can i see Dell Logo on boot with A09 Bios Revision: YES

- can i acces BIOS menus with F12: YES

- can boot from whatever (dvd, usb, hdd): NON - the screen seems alive but blank

- can run diagnostics: NOT SURE as i see nothing on the display

- can hear the beeps when i power on the laptop without RAM, HDD, battery: NON

- when i power on, the fan stars few seconds that stops => pipes and CPU became hot (i can still touch it, is not boilling)

Actions without results:

- swaped RAM

- long press on power button to remove static bshhhit

- pull out/ pull in the LVDS cable on the MB

- tried with a 100% working RAM

- try it with an external monitor on VGA port

- try it another Dell charger

- inspected visually and shaked the USB cables (nothing wrong, nothing short to ground)

- cried on my daughter shoulder (jocking)

- hit it 6420 times with a small 20kg hammer (jocking, but the ideea is there...)

Questions:

- what to further do/try ?

- how could i know if it has a discrete graphic card ?

- what is a better ideea - buy only i5 CPU or a MB ?

Thank you in advance

I will send beer money to the one who will provide THE solution...

0 Kudos