Laptops General - Read Only

Last reply by 04-15-2016 Solved
Start a Discussion
2 Bronze
2 Bronze
1987166

nVidia Geforce GT 650M NOT DETECTED on Inspiron 17R SE 7720 after BIOS A11 Update

Hi everyone,

A week ago I did some updating on my Inspiron 17R SE 7720 including Bios update to the A11 version. Unfortunately after this update I realized that the nVidia Geforce GT 650M graphics card was gone from my system.

I read other posts and people that have come across this issue suggested that re-installing the bios would fix the problem, however in my case it did not.

Also I have installed the newly released BIOS A12 and A13 versions but non of these have fixed this issue.

Also re-installing windows does not either fix this as suggested by others in other posts.

I have also run the computer diagnostics from the bios and the card does not show up there either, is like if the nVidia Geforce GT 650M graphics card was not installed on the system.

Lastly I have run a version of Ubuntu on my Inspiron 17R SE 7720 and run a system check and neither the card is detected, just the Intel HD Graphics 4000 is detected on windows or linux.

Please someone from dell help us fix this issue, as it is definitely a BIOS PROBLEM.

If you are one of the unlucky ones like me that saw disappeared the nVidia Geforce GT 650M graphics card from your system, please share your experience with me.

Thanks for your responses.

--------------------------edited on 22/10/2013 by me (luiavag)------------------------------

After 7 exact months of supplition since I started this discussion Dell has finally done it.

Bios A16 addresses and fixed this isue.

Link to Official Inspiron 7720 System BIOS A16:

http://www.dell.com/support/drivers/uk/en/ukbsdt1/DriverDetails/Product/inspiron-17r-se-7720?driverI...

Finally, we can get back to gaming!

LOL

Replies (565)
3 Silver
548

There is something else to be aware of - if you go down the replacement motherboard route. There are apparently two models of motherboard for the 7720.

My failed replacement refurb (and the original board) were identified as:- Board: Dell Inc. 072P0M A00.

The working board I have now is identified as:- Board: Dell Inc. 04M3YM A00.

I am not at all sure what the differences are, although there being different boards could also account for why some board changes work whilst others don't.

Use Belarc Advisor to check the motherboard model details.

... If only Carlsberg made laptops

2 Bronze
2 Bronze
548

Board: Dell Inc. 04M3YM A00

That's mine, so looks like the one you have and is working for you, failed for me. Sucks.

2 Bronze
2 Bronze
548

I have an engineer coming tomorrow to replace the GPU.

2 Bronze
2 Bronze
548

My odyssey with the 17R SE is over. My seller takes back the notebook and refund me my money :) 8 weeks horror trip are to END!

This was my first laptop from Dell. And certainly the last!

Good Bye DELL :) :) :)

2 Bronze
2 Bronze
548

Cool, well, we'll see how that goes for you! If it fails then just say screw it and install Mac OSX Mountain Lion :) [*hint* the 7720 can natively run OSX ;) though you'll only get CI/QE with the intel hd 4000 as of yet! LOL, but everything works pretty great! details below]

I myself am not totally sure where the problem lies, or where it stems from, but have been following this thread since I've had the issue myself! I bought my 7720 back in October of 2012 (On halloween now that I remember) at BestBuy. One of the reasons I chose this model was because along with having an i7 (3630QM) it also had 8gig ram and a dedicated Nvidia GPU. (I've always had issues with ATI's and now it seems maybe I would've been better of trying my luck again with them LOL) It just happened to have Windows 8 pre-installed [I guess since Windows releases new OS's around October] but that was just by chance when I happened to buy it and I actually like Win 8 so no problem there...

HOWEVER, I would like to note that I was happily using my nvidia 660m (it was always showing up as that even though I guess it might technically be the same as a 650m) for many months, upon months with no issues whatsoever...

I'm not sure what bios was loaded on my laptop at the time / before I experienced this dissapearing nvidia card issue, but whatever version it was, it was a screwed up bios... I never since the day I bought it could access the bios at startup (setup f2, or f12 boot menu) and I thought that was something new because of UEFI, so I didn't think anything of it, although I didn't like it. I was like if this is what UEFI is like give me regular BIOS back! The only way I could access the bios setup, was by choosing an option from windows 8 LMAO... but luckily when I did access it that way at least once, I turned secure boot off (prevents any other OS from booting except the factory installed windows 8, which is stupid... you would only 'secure' yourself from being able to boot anything if your windows 8 screwed up) and I enabled whats now called 'legacy' booting (from USB or whatever) since UEFI came out.

Well sure enough, thanks to that faulty bios... Eventually my windows 8 screwed up! It happened when I tried to wake my computer from it's hibernation or sleep whichever it was, and all I got was a BLACK SCREEN! It made me nervous I'll admit, I thought something horrible had somehow happened... booting from a CD/DVD wouldn't work, and since like I said before my bios was screwed up, I couldn't even access the boot menu to choose to boot from DVD or anything. However upon inserting a USB stick, it would say 'Operation system not found' which put a smile on my face, since then I saw it was actually trying to 'legacy' boot from a USB stick! Put Ubunutu on the USB, booted from it, and played around with the Ubuntu live USB for a day or so. (Seeing my computer working again, knowing nothing was actually wrong with it made me so happy!)

So I decided I would try to get my windows to boot again, I placed a windows boot manager onto a USB stick and played around with it for a bit... Following Microsoft's instructions I had to accommodate for UEFI... So this line was in there 'path                            \Windows\system32\winload.efi' on my Windows Boot Loader entry... By changing it to winload.exe just for shits and giggles because winload.efi didn't seem to work. (this was because I was booting off the USB in legacy mode (not EFI) so at that point the EFI executable was invalid, and luckily windows 8 still does have a winload.exe for legacy boot support, even though they say that there isn't)

I GOT IT TO BOOT WINDOWS 8! :)

So now back in my Windows 8, I immediately fired up a game to enjoy using my computer once again as I hadn't been back on windows in a few days... The Nvidia card was still working fine... Though this was <ADMIN NOTE: Substitute character removed as per TOU> position to be in... I had to use a USB stick just to boot windows... And for the life of me nothing I did to fix my hard drive's Windows Boot Manager allowed me to boot directly from the HD anymore... I wondered what could be the issue, so of course what does anyone do? They come here to get the latest drivers and updates... Saw there was a new BIOS A14, so I went ahead and installed it, thinking the BIOS is the problem because it was weird that I couldn't even get F2 or F12 to do anything on boot (and others could even though they had UEFI too) and After flashing A14, I could then press F2 or F12 to get either BIOS setup, or the boot menu to appear! and what do you know UEFI started working again and just started booting Windows 8 again! :) So I was happy that everything was how it should be now, and it never was like that since I bought it... [OR SO I THOUGHT :(]

However, when I tried to play my game next (relatively soon after I updated BIOS, like the same day), I was like hmm... it seems a bit choppy, and not quite as smooth, is my nvidia card even enabled right now... (usually before I could select which games or applications I wanted to use the NVIDIA card. Most games would actually use the nvidia card even if you didn't specify, other's you would have to select NVIDIA card through the NVIDIA configuration, to make sure that game is going to use the better GPU.

This time, when I double clicked the NVIDIA config to see whether my game was using it or not and to change it if it wasn't, it came up and said, "No NVIDIA graphics device has been detected".. Wait WHAT?  What do you mean I was literally just using it before I updated my bios to fix my other issue...

Frustrated as all hell, I messed with it and rebooted, and messed with BIOS settings and booting different OS's and nothing seemed to work! search for '17r nvidia' and THE FIRST THING THAT COMES UP, is this thread! :( ugh...

If I would've known that updating the BIOS (which I kind of had to do to get windows 8 to boot again without a USB stick, and to access my F2 setup and F12 boot menu) I would've stuck with having to boot windows from a USB, and just dealt with it like that, had I known updating my BIOS would've broke my NVIDIA CARD! <ADMIN NOTE: Substitute character removed as per TOU>

So out of frustration, and basically the only thing enjoyable on this computer now is the i7 CPU... I decided to see if the 7720 just so happens to have the right kinda hardware to run Mac OSX natively (not a virtual machine)

AND>... IT CAN! :) lol So about the only good thing I figured out in all this bios problems, then nvidia problems, is that this computer can actually run OSX. well Mountain Lion that is, not sure about earlier releases... But it can definitely run ML 10.8.x :)

So in summary, Terry, A15, that better not have been the BIOS supposed to fix the issue, and where did you get A09 from? I think that' a typo, it was A14 before A15 popped up... There seems to be a disconnect between the BIOS writers, and support. Since as other's have mentioned, it doesn't even say anything about the nvidia issue.

However, since I believe first hand that the BIOS broke my nvidia card, I think a BIOS update can FIX it :) We just gotta get the BIOS coder team on it! Not some oh yea we know about the issue but the people that really need to know about it DONT! LOL that's a total disconnect if that's what's going on!

For now I suppose I'll just be coding something up in XCODE on my 7720-Hackintosh ;) And Terry the way you are talking to us, it seems like you have one of these 7720's yourself! If you do, just run OSX on this <ADMIN NOTE: Substitute character removed as per TOU> LOL until they fix our bios for us!!

I have hope! Nahhh A15 wasn't the fix! They are just taking a while with it, because IT HAS TO WORK! they don't want to let us down by releasing a BIOS that addresses the issue but doesn't fix it!

So continue to have a little faith! I am :) 

Dell Technologies
548

I have received confirmation from engineering that A15 is the correct bios that should help with issues where the Nvidia GPU is not being detected by Windows.   If you are currently having difficulties with Windows seeing the Nvidia GPU on your Inspiron 17r SE please update to A15 (if you have not already done so) and then please post here with the results.  I will be passing this information directly to engineering.

If A15 has failed and you have not already private messaged me please do so as well and in your message please include the service tag.  

TB

Specialize in Laptops, Mobile Devices
#IWork4Dell

2 Bronze
2 Bronze
536

For those of you interested in getting OSX running on your 7720, I recommend the latest version of iATKOS ML (Mountain Lion) I used iATKOS ML2 when I installed mine.

The iATKOS setup works fine, but then you'll have an issue actually booting the installed OS unless you copy the 'GENERICUSBXHCI' .kext (kernel extension/ mac driver) to your /System/Library/Extensions folder (use the iATKOS setup USB / DVD with terminal to do so if you don't have another mac to use)

http://sourceforge.net/projects/genericusbxhci/files/

Also these are the .kext's (kernel extensions / mac drivers) that I chose in the iATKOS installer, or found separately... to get things to work!

VoodooPS2Controller.kext (for touchpad)

AppleSmartBatteryManager.kext (for showing battery percentage / power management)

AppleIntelCPUPowerManagement.kext (similar to above + related to your CPU)

AppleHDA.kext (for audio / sound to work)

AppleACPIPlatform.kext (related to hardware level, getting most things to just 'work')

FakeSMC.kext + EvOreboot.kext (just to make your pc hardware jive with apple's OS)

And this for ethernet (as of course the built in wifi device doesn't work, either replace it with one that does, use ethernet, or use a USB dongle wifi device mac compatible)

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

(scroll down to bottom and select: one of those download links, ex. US1)

MacOS 10.7 on Intel-based Mac computer 2.0.6 2011/9/29 147k CN US1 HK1 UK1 US3 US2

Until we fix our nvidia gpu, I guess running mac is the coolest thing this computer can do at the moment! lol!

So, enjoy this in the meantime, while we await for our FIX :D

2 Bronze
2 Bronze
536

Can you tell me why the new bios does not work ? I despairing with this problem !

2 Bronze
2 Bronze
536

I have the same problem. My laptop still not detect GPU. I updated BIOS, but it not help. All information I post here. I hope for your help.

2 Jasper
2 Jasper
536

So far the new bios A15 has managed to fix Zero peoples issues despite being specifically for this posts issues. thats pretty awesome work there for 4 months of bios development programming work. I especially love how Its not even mentioned in the bios fix and enhancement release notes. So basically terry Its absolutely a crock <ADMIN NOTE: Substitute character removed as per TOU> and your team have lied to you. it clearly has.nothing to do with this problem and postpones the issue while.more.people run out of or void their warranty.  really poor support here dell. What do you advise us who had a mobo replacement who are worried the problem will come back?  flash a15 or not?  after all it was a bios.flash that broke it in the first place  sent via xperia mobile

Latest Solutions
Top Contributor