Highlighted
rterrain03
Bronze

Dell D610 1.5GB 160GB Internal HDD Hard Error, Won't read when installed

I have a dell d610 with a pentium m 1.86, 1.5GB of Ram, 160Gb IDE HDD,

 The Machine will not read the HDD in dell's version of BIOS when the HDD is installed internally in its primary drive bay

 I get the message "no bootable devices f1 to continue or f2 to start setup utility"

 f1 Leads to  Internal HDD Hard Error

Sometimes it will start the OS  but only get to the splash screen before the login and then freeze, other times it will run the OS but it gives I/O error when trying to read the disk, But most of the time, It will load through BIOS then Give me the Error  "Internal HDD Hard Error" f1 to continue f2 setup utility

reinstalling windows doesn't help,

 

     luckily this laptop boots off of USB and I have the HDD running from the usb adapter.- Same Hard Drive,

 Jumper is not installed,  for this is the master setting

 What do you guys think ?  

 Questions  welcome

0 Kudos
6 Replies
ieee488
Diamond

Re: Dell D610 1.5GB 160GB Internal HDD Hard Error, Won't read when installed

if there is no OS then there is no bootable device
0 Kudos
rterrain03
Bronze

Re: Dell D610 1.5GB 160GB Internal HDD Hard Error, Won't read when installed

Windows xp  is installed and it runs fine when the same hard drive is running the same laptop via usb instead of ide , and yes the adapter is installed, any ideas ?

0 Kudos
ejn63
Diamond

Re: Dell D610 1.5GB 160GB Internal HDD Hard Error, Won't read when installed

What does the BIOS report for the drive?  F2 at powerup.  If it's being reported as "not installed", be sure you've transferred the black blade adapter from the back of the original drive to the pins of the new one - without that adapter, the drive isn't connected to the system.

 

0 Kudos
rterrain03
Bronze

Re: Dell D610 1.5GB 160GB Internal HDD Hard Error, Won't read when installed

Yeah I made sure to transfer it over. for some reason it likes to run fine when im booting from the usb port with the hard disk attached to a "usb to ide" adapter

Any ideas ?

0 Kudos
ejn63
Diamond

Re: Dell D610 1.5GB 160GB Internal HDD Hard Error, Won't read when installed

If Windows was installed to the drive that way, AND the BIOS reports the drive correctly, it just means Windows needs to be reinstalled onto the drive when it's mounted in its proper position.

If the BIOS doesn't correctly report the drive and its size -- and/or you cannot install Windows to the drive when it is mounted in the system, it likely means there is a problem with the mainboard (drive controller and/or connector) in the system.

 

0 Kudos
rterrain03
Bronze

Re: Dell D610 1.5GB 160GB Internal HDD Hard Error, Won't read when installed

I think its the ide controller, i updated the bios and it still won't boot from the hdd when its got the adapter on it and installed and the hdd is set as a boot device in the list of boot sequence(bios)

 Hooked it back up to the usb port via  ide/usb adapter and booted from usb.

 I guess I could just hard wire the adapter , or get another board(which would be pricey on a old laptop)

 Plus its running ubuntu now  what do you guys think ?

0 Kudos