Capulet
Copper

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

Hey Justin C

I have an Alienware 17R4. HWInfo report [View:/cfs-file/__key/communityserver-discussions-components-files/3518/DESKTOP_2D00_H4J3BG7.LOG:550:0]

My problem is that when i got my laptop it was running in the "raid on" mode in the bios.

After wanting to do a clean install with the latest updated Windows 10 Pro OS i found that when going through the setup that i cant see my Toshiba 512 NVME drive. I loaded the latest IRST drivers on a flash drive....clicked on the "have drivers" or whatever the button is called and pointed it to the drivers on the flash drive......NO LUCK. 

I followed the "How To" in the following link

https://www.alienwarearena.com/ucf/show/261122/boards/technical-support-1/forumpost/clean-install-wi...

This also made no difference to my problem......i tried it all.

my only option was to turn raid off and install windows using AHCI mode. This seems to work but unlike you i can clearly feel the speed difference. 

Now that windows is loaded under the AHCI mode some strange things are happening. My system thinks my drive is Mechanical and not even an SSD. In the IRST software the NVME drive is not even visible. The only drive visible is my 1TB 2nd drive.

  

I would really like to use my system the way it was when i received it but i have spent hours on the phone with dell support and even they are stumped. 

Please if anyone can help it would be much appreciated. 

Regards Capulet

0 Kudos
Gtabhuvan
Copper

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

@ capulet

download the irst drivers from the downloadcenter.intel.com/.../Intel-Rapid-Storage-Technology-Intel-RST-

in the alienware forum site they have given old driver link which is of 2015 year.

the above which i gave is the new intel rapid storage technology drivers 2017 , try downloading it and keep it in seperate usb not the "os usb" and repeat the same procedure, at first time it may say that failed to load drivers and at the secound time it may  success but remember this , you have to extract the driver and copy to the usb.

extracting the driver IRST:

extract till you get the iaAHCIC files

only these files are recognized at the time of installation.

even i have the same problem.

0 Kudos
Capulet
Copper

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

Hi Gtabhuvan

Thank you for your advice. Unfortunately i have already tried this method with this driver and and i still cant seem to get it to show. Dells solution is to replace the drive with a Samsung PM961 or 960 Pro. I believe this is a win for me but i don't think it will solve my issue. It seems they have a way of injecting the driver when you use their custom image. I have no idea what my next attempt should be.

0 Kudos
Saltgrass
Diamond

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

@Capulet, I was looking at the thread and noticed some things.  Your reference instructions for installing are for a R3 system.  From what I can tell, it only has a SATA interface, where the R4 has the PCIe interface.

Is there any difference on which M.2 slot you use?

When you downloaded the IRST drivers, you downloaded the x64 Floppy version?

I have the Toshiba drive in my system and running as SATA.  I have not tried to clean install on it but I did test trying to install on a NVMe drive.  My system could not see the drive in that configuration but I did not try to use the IRST drivers.   I do not know how Dell images the OEM drives but I assume that is done prior to being placed in the system.

As you probably know, a Samsung 960 Pro can be installed as a PCIe drive as long as you are installing in the UEFI configuration.  On my system, it is very fast when using the Samsung NVMe driver .  It is slow if using the Microsoft one.  I do not know about an Alienware system.

The F6 IRST drivers should allow the Toshiba drive to be seen during an install but something you could try is install the Toshiba as a NVMe drive and once Windows is running and the IRST Windows driver has been installed, use the msconfig.exe method to change the controller for the drive.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Capulet
Copper

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

Hey Saltgrass

The instructions given by that user on that forum was used by another R4 user and he had the same issues.....it did not work. I have tried to use different NVMe slots but it also makes no difference.

I did download both the floppy version and the other version......but the result was the same. I have found the NVMe drivers for the PM961 but it seems al lot of users have another problem with that drive. Apparently you cant use the Samsung driver magician software. And can only install it as AHCI and not with RAID turned on in the bios. According to what io have read in some forums is that when it runs as AHCI it only utilizes 2 of the 4 lanes available. I'm not sure if this is true but it kinda makes sense.

I see you mentioned the F6 during startup. I actually went into the windows setup and when it came to the drive management section i clicked on the "have disk" button.....browsed for the drivers on the extra USB i created.....unzipped and fully extracted. But nothing happened. Will the F6 before boot make that much of a difference?

My biggest concern is that most of my drive management software detects the NVMe drive as mechanical or at least treats it as one. The IRST software does not even detect the drive.

Strange Stuff we are dealing with here lol

0 Kudos
Saltgrass
Diamond

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

The F6 is just a holdover term from the days when a Floppy drive was used for the drivers.  As you mentioned, during an install in Win 10 you just need to point to the drivers at the appropriate time.  Back in the days of Win 7 when I was loading USB 3.0 drivers, I had to load both the basic USB 2.0 drivers and the 3.0 version.  I do not know if any such situation occurs in this instance.

Windows has the drivers necessary to do normal installs.  I think the problem comes when the NVMe controller is recognized and confuses the system so the correct drivers are not seen/loaded.

The downloaded Intel drivers does have the RAID version of the driver?  I might download and check unless you know for sure.

Maybe you should start a separate thread if you think it would be worth it..

I found an Intel site which seem to describe the process.  It states you choose the iaStorAC.inf file and let it install the drivers, then continue the install.

https://www.intel.com/content/www/us/en/support/articles/000021493/mini-pcs.html

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Not applicable

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

Hello,

I have a Latitude 5580 with Toshiba M2 (THNSN5512GPUK) NVMe. I am trying to install Windows 10, but I can't because of Windows not seeing drivers. I've tried to load the mentioned drivers but nothing seems to work. The Toshiba i've got is Toshiba RG4 from what is says on Dell website.

Any help would be appreciated.

0 Kudos
Capulet
Copper

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

@Dell-Justin C

Can you please provide me any info you possibly have on the Samsung PM981 MZVLB512HAJQ-000D1

I have googled this drive and after about 2 hours of some to no results i gave up. Dell is replacing my NVMe drive with this model. And there is literally no info available about this drive. Another thing if you can advise me on is that on Samsungs own site there is no driver support for any drive past the Official Samsung 960 NVMe.

Regards

Capulet

0 Kudos
DiscostewSM
Copper

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

Justin,

I recently got myself a new Inspiron 7577, but I'm getting the exact same issue as vikram0136 is having. The drive in question is also a KXG50ZNV256G NVMe Toshiba 256GB. The drive is rated to do roughly 2700 MB/s sequential read (no problem there), but it's also supposed to do about 1050 MB/s sequential write. The latter of these two drops to about 350 MB/s max, but it's not consistent. It fluctuates from time to time, and I've tested this across a good dozen tests with CrystalDiskMark, which shows it generally going down to 350 MB/s (I did have one test that shows it briefly at 17 MB/s for the first of 5 runs for the test), but as high up as ~1100 MB/s (due to some variance). The thing is, if I do a factory reset, I can guarantee that it'll be at the tip-top of its capability for a bit, then randomly, it'll drop down, even if I do nothing. No additional updates either. Just letting it sit idle. Here's the general difference between when it would write at the appropriate speed and when it wouldn't.

When using HWInfo, the PCI Express Root Port #1 shows  a Max Link Width of x4, but Current Link Width is "Not Negotiated". Clicking on the SSD under Drives shows no mention of PCIe lanes. However, if I open up the Intel Rapid Storage Technology program, it sees the drive, and under Advanced, it says the controller type is NVMe, PCIe link speed at 4000 MB/s, and PCIe link width at x4. The organization under Device Manager does match what you have when running in IRST RAID ON (when the view is ordered by connection).

Besides CrystalDiskMark, I also did a test of copying some large files under Win10 from one directory to another (within the same NVMe drive), and I found something interesting about it. When it was actually writing at the appropriate speed, the graph was generally smooth. But, when the write was not performing as it should, the graph shows waves, like it attempted to go higher, then tripped downward, and repeated this up and down throughout the copy.

0 Kudos
Moderator
Moderator

RE: Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

@Betthethao,

It would be a rather involved process to troubleshoot that issue over a forum. You're welcome to send me a friend request with your service tag and we can work together. A quick work around may be to simply switch to AHCI mode, as stornvme is native to Windows 10 and doesn't require installation. Meaning, the drive will just show up as normal during Window installation.

@Capulet,

I responded to your friend request.

@DiscostewSM,

Thank you for your detailed description. Please send me a friend request and we'll work to figure it out.

Justin C

Dell Technical Support L3 | Project Sputnik

Dell Support is also on Twitter! https://twitter.com/DellCaresPRO

 

0 Kudos