Highlighted
lmonde
Bronze

Dell Studio XPS 1645 BIOS problem

Here is what I sent through to Dell:

------------------------------------------------------------------------------

Description of problem.
Earlier this week, I tried to update the bios of my laptop, by downloading the program from the Dell website. The flashing program had almost finished, when Windows froze entirely. I left the computer for 30 minutes, but with still no response, I was forced to unplug the AC and battery. Since then, the laptop does not respond at all to any input (power button, AC input, etc).

Description of any troubleshooting steps you have taken.
I looked online and found this article:
http://forum.notebookreview.com/dell-xps-studio-xps/451601-bricked-xps-1645-help.html
where the second post has instructions for fixing this sort of thing. I followed them, but it does not look to have helped. I got the BIOS file by running the BIOS program from the Dell website, and finding the temporary location it extracted the BIOS1.WPH file, and putting it on the USB.

To get the laptop to power on into BIOS recovery mode (with the side LEDs turned orange), I had to hold down the end key, and then release it at the same time as pressing the power button. I did this with only AC power.
I tried the process with 2 USB drives - one of them had an LED access light, which flashed for about 10 seconds total once I had pressed the end key + power button combo, but then no further access. I then left the laptop for sometime (more than 10minutes) and powered it off, and tried to boot it, with no luck.

I then tried a different USB key (that does not have an access LED), and after about 3 minutes, the laptop turned itself off. Taking this as a good sign, I removed the USB, and tried to power the laptop on, but again I had no luck.

I tried many combinations of waiting and powering on and off, as well as different BIOS files, named as BIOS.WPH or BIOS1.WPH, etc, but all with no success.
It seems that the first USB was not working, as if I go into the BIOS recovery mode with no USBs, it will just sit there indefinitely, just like it does when the first USB is plugged in. It is only with the second USB, it turns off after about 3 minutes.

------------------------------------------------------------------------------

Dell have replied and said "Your motherboard is broken, pay us ~$500, and we'll put a new one in the laptop". Obviously, I do not want to pay this sort of money, and I was hoping someone else might have some knowledge about this - it seems so close to working! 

Tags (2)
0 Kudos
11 Replies
Zebra44
Copper

Re: Dell Studio XPS 1645 BIOS problem

95% of the time when the BIOS flash does not 'flash' your motherboard is fried. Sorry, but Dell is probably correct about this problem.

Now

0 Kudos
lmonde
Bronze

Re: Dell Studio XPS 1645 BIOS problem

Even though it still boots into the BIOS recovery mode (the circles on the hinge light up orange)?

I feel like I just have the wrong files or something, it gets so close...

0 Kudos
fullmd
Copper

Re: Dell Studio XPS 1645 BIOS problem

Dell is a aware of this problem yet they still have done nothing about it. you would figure the least they could do was fix the update or disable the llink for it. i have a Studio xps 1645 that is 3 days old. and this happened to me i hope it falls under warrenty.

0 Kudos
Meggie13
Silver

Re: Dell Studio XPS 1645 BIOS problem

What bios did you flash to?: I flashed to A10 and have problems with more heat and connections to the net. If you go to laptop reviews on the net there are disadvantages with the A10 bios. I am trying to get back to the A09 which my computer worked like a charm with it.

 

0 Kudos
lmonde
Bronze

Re: Dell Studio XPS 1645 BIOS problem

I was attempting to flash to A10, but now, because the process failed, I have no bios as such - hence the problem.

If you could link me to the A09 bios though, I could try the process I have been going through to get it on. The Dell Australia website only has A06 and A10 bios files on there.

0 Kudos
Meggie13
Silver

Re: Dell Studio XPS 1645 BIOS problem

http://support.us.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R269189&f...

 

 

Let me know if it works. The site is very slow to load. At least you know how to revert back which I am still going to do but afraid to try. I need to restore a backup from ghost before I do since the Dell tech changed a lot of settings in my computer. It worked great prior to him changing things (he tried to get more then 1 1 /2) hours from the battery). Now it does not work as well and gets hotter and the internet at times won't connect unless I do it manually.

Good luck.

0 Kudos
lmonde
Bronze

Re: Dell Studio XPS 1645 BIOS problem

I'm not quite sure you get what I mean - I can't ghost or anything, when the power is plugged in, I get no response whatsoever from any button, including the ON button. The only way I can get it to do anything is if I hold down the END key for about 3 seconds, plug in the power (at which point the circles on the side flash orange for a split second <though I just realised that this happens even if I don't hold down END>), and then release the END key 3 seconds later, at which point the keyboard lights up, the bluetooth light turns on, the fan spins up to max speed, and the circles go orange. The screen never turns on.

A new development though! I got the A09 BIOS, and put it on my flash drive, and just tried it out. Now, about 30 seconds before the laptop turns off, the circles on the side flash between white and orange, for about a second each, and then it turns off. I then unplug the power, and take out the USB, replug the power, and still nothing.

Does flashing side LEDs mean anything to anyone??

0 Kudos
lmonde
Bronze

Re: Dell Studio XPS 1645 BIOS problem

Apparantly, yes:

http://en.community.dell.com/support-forums/laptop/f/3518/p/19330692/19690712.aspx

Step 13 is where mine fails... It does everything else as expected, but it just doesn't boot!

Someone else said on a forum in the comments about flashing amber and white LEDs:

http://smurariu.wordpress.com/2010/03/28/bricked-dell-xps-1340/#comment-81

 

Maybe I need a better USB...

 

0 Kudos
Saintist
Copper

Re: Dell Studio XPS 1645 BIOS problem

Hi,

 

Not sure if you sorted your problem out, but i have a suggestion :

as with other dell laptops (Studio 1747)    i have had similar problem and i solved the problem with the following (Dells Instructions):

  • Remove main battery.
  • The rear plate for the system is held on by 6 screws. Remove all 6 screws and remove the plate.
  • With the battery compartment nearest to you in the top left corner you will see the CMOS battery.
  • Using a minimal amount of force and a flat tool, pry the battery gently from its seat (it is held on by sticky substance).
  • Unplug the battery from the motherboard by disconnecting the white connector.
  • Wait for two to five minutes and then reattach the battery cable and reseat the battery.
  • Replace the rear plate and the retaining screws and reseat the main battery.
  • Attach the AC adapter and power on the system.
  • If a 5 beep code is heard, switch off the system and restart it.
  • ** I know your bios did not finish updating so this might not work, but worth trying.
  • Also.... remove your hdd just  as an extra measure  when you try the blind bios recovery.

0 Kudos